Bug 180254 - star stops appending files to archive
star stops appending files to archive
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: star (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 15:05 EST by Chris Stankaitis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 08:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Stankaitis 2006-02-06 15:05:19 EST
Description of problem:

after appending 22 files to a (s)tar ball I am unable to append more files


Version-Release number of selected component (if applicable):

star-1.5a25-6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. star -xattr -H=exustar -/ -u -f /root/default-configs-rhel4.tar /root/.rpmmacros
2.star -tv -f default-configs-rhel4.tar

  
Actual results:

it appears to say it's appended the file ok..

star -xattr -H=exustar -/ -vvv -u -f /root/default-configs-rhel4.tar
/root/.rpmmacros
a      75 -rw-r--r--@  1 root/root Nov 14 18:06 2005 /root/.rpmmacros
star: 8 blocks + 0 bytes (total of 81920 bytes = 80.00k).

but when you view the archive it's not listed there

Expected results:

file gets appended to the archive
Comment 1 Chris Stankaitis 2006-02-08 15:03:54 EST
another test.

# star -xattr -H=exustar -/ -u -debug -f /root/newconfig.tar /etc/profile
star: Block size 20 blocks (10240 bytes).
hdrtype:          8
pr_maxsize:       unlimited
pr_flags:         0x713
pr_xdflags:       0x7
pr_fillc:         '0'
pr_diffmask:
pr_nflags:        0x7
pr_maxnamelen:    4096
pr_maxlnamelen:   4096
pr_maxsname:      100
pr_maxslname:     100
pr_maxprefix:     130
pr_sparse_in_hdr: 0
dev_minorbits:    8
npat: 0 narg: 0
npat: 0 narg: 0
exustar archive.
hdrtype:          8
pr_maxsize:       unlimited
pr_flags:         0x713
pr_xdflags:       0x7
pr_fillc:         '0'
pr_diffmask:
pr_nflags:        0x7
pr_maxnamelen:    4096
pr_maxlnamelen:   4096
pr_maxsname:      100
pr_maxslname:     100
pr_maxprefix:     130
pr_sparse_in_hdr: 0
R /root/passwd.sh
R /usr/local/bin/typescript.sh
R /root/.rpmmacros
R /root/.ssh/authorized_keys
star: First  EOF Block OK
tblocks: 19 blocks: 1 blocksize: 10240 parts: 0 bigcnt: 0 fifo_cnt: 0
Blocks: 19
bigptr - bigbuff: 10240 6314E0 633CE0 633AE0 lastsize: 10240
star: Second EOF Block OK
used 1013 bytes for update cache.
tblocks: 20 blocks: 2 blocksize: 10240 parts: 0 bigcnt: 9728 fifo_cnt: 0
Blocks: 20
filepos: 20480 seeking to: 10240 bigsize: 10240
star: Inappropriate ioctl for device. Error sending mtioctl(8, 0) to
'/root/newconfig.tar'.
Is a file: lseek()
star: hardlinks: 0 hashents: 0/256 maxlen: 0
star: 3 blocks + 0 bytes (total of 30720 bytes = 30.00k).

# star -tv -f newconfig.tar
    544 -rwx------@ root/root Jan 17 15:29 2006 /root/passwd.sh
    408 -rwx------@ root/root Jan 17 15:29 2006 /usr/local/bin/typescript.sh
     75 -rw-r--r--@ root/root Nov 14 18:06 2005 /root/.rpmmacros
   1225 -rw-r--r--@ root/root Jan 17 15:29 2006 /root/.ssh/authorized_keys
star: 3 blocks + 0 bytes (total of 30720 bytes = 30.00k).
Comment 2 Peter Vrabec 2006-02-09 07:44:04 EST
It is fixed since star-1.5a28.
It's a problem to create a patch for star-1.5a25, there is a big diff between
these versions.

Note You need to log in before you can comment on or make changes to this bug.