Bug 180256 - alarm() not returning correct value
alarm() not returning correct value
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 180257 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 15:20 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 16:18:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2006-02-06 15:20:04 EST
With glibc-2.3.90-30.i686.rpm installed February 1 along with about 1,000 
other FC devel packages, including kernel-smp-2.6.15-1.1884_FC5smp and gcc-
4.1.0-0.18, this C program:

#include <unistd.h>
#include <stdio.h>

main()
{
  alarm(5);
  printf("alarm returned %d\n", alarm(0));
}

prints "alarmed return 0'.  It *should* print "alarm returned 5" or 
perhaps "alarm returned 4".
Comment 1 Jonathan Kamens 2006-02-06 15:21:49 EST
*** Bug 180257 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2006-02-06 16:18:09 EST
Sorry, can't reproduce this.  On all arches I have tried (which includes
i686), with glibc-2.3.90-36 the program prints 5.
Comment 3 Jonathan Kamens 2006-02-06 16:54:09 EST
It was a kernel bug.  It's gone in the current Raw Hide kernel.

Note You need to log in before you can comment on or make changes to this bug.