Bug 180257 - alarm() not returning correct value
alarm() not returning correct value
Status: CLOSED DUPLICATE of bug 180256
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 15:20 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 15:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2006-02-06 15:20:39 EST
With glibc-2.3.90-30.i686.rpm installed February 1 along with about 1,000 
other FC devel packages, including kernel-smp-2.6.15-1.1884_FC5smp and gcc-
4.1.0-0.18, this C program:

#include <unistd.h>
#include <stdio.h>

main()
{
  alarm(5);
  printf("alarm returned %d\n", alarm(0));
}

prints "alarmed return 0'.  It *should* print "alarm returned 5" or 
perhaps "alarm returned 4".
Comment 1 Jonathan Kamens 2006-02-06 15:21:39 EST

*** This bug has been marked as a duplicate of 180256 ***

Note You need to log in before you can comment on or make changes to this bug.