Bug 180293 - hang with "tcb table full"
hang with "tcb table full"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 17:30 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.5.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 22:07:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace-4.5.14-alt-tcb.patch (3.56 KB, patch)
2006-03-28 19:55 EST, Dmitry V. Levin
no flags Details | Diff

  None (edit)
Description John Reiser 2006-02-06 17:30:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Running strace on the internal testcase nptl/tst-eintr1 of glibc gives messages
  [tcb table full]
  ptrace: umoven: No such process
  trace: ptrace(PTRACE_SYSCALL, ...): No such process
and the process is hung.  There is no response to SIGINT [^C]; "kill -KILL" is required.



Version-Release number of selected component (if applicable):
strace-4.5.14-1

How reproducible:
Always

Steps to Reproduce:
1. strace -o strace.out glibc/build-i686-linuxnptl/nptl/tst-eintr1
2.
3.
  

Actual Results:  The strace is hung as in Description, with message "[tcb table full]".  "/bin/ps axl" shows
-----
F   UID   PID  PPID PRI  NI    VSZ   RSS WCHAN  STAT TTY        TIME COMMAND
0   500  3024  2256  17   0   1744   640 wait   S+   pts/0      0:00 strace -f -o strace.out /home/jreiser/rpmbuild/BUILD/glibc-20060202T0507/build-i686-linuxn0   500  3025  3024  18   0   1484   420 ptrace T+   pts/0      0:00 /home/jreiser/rpmbuild/BUILD/glibc-20060202T0507/build-i686-linuxnptl/elf/ld.so --library-1   500  3026  3025  19   0      0     0 exit   Zl   pts/0      0:00 [ld.so] <defunct>
-----


Expected Results:  Successful termination in a couple of seconds.

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:18:19 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Dmitry V. Levin 2006-03-28 19:55:26 EST
Created attachment 126946 [details]
strace-4.5.14-alt-tcb.patch

There is a classic time-of-check-time-of-use race in internal_clone()
and internal_fork(): tcbtabsize is checked in "entering" phase of syscall
deparses, and alloctcb() is called later in "exiting" phase.
trace() also calls alloctcb() without check.

Proposed patch should fix this race.
I have no nptl/tst-eintr1 nearby to check it myself though.
Comment 3 Dmitry V. Levin 2006-11-26 06:40:06 EST
Fixed upstream.
Comment 4 Roland McGrath 2007-01-11 06:15:48 EST
these bugs are fixed upstream in the coming 4.5.15 release
Comment 5 Roland McGrath 2007-01-16 22:07:58 EST
4.5.15 in rawhide and in updates for fc5 and fc6 fixes this.

Note You need to log in before you can comment on or make changes to this bug.