Bug 180326 - cairo.gtk doesn't get built
cairo.gtk doesn't get built
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pycairo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 05:51 EST by Pekka Pietikäinen
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 11:42:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2006-02-07 05:51:34 EST
Description of problem:

In the current pycairo rpm the cairo.gtk module doesn't get built. This is
caused by a check in configure that wants pygtk2 < 2.7.0, whereas rawhide now
ships 2.8.4. 

I changed this check to a < 2.9.0 and my cairo.gtk-using app seems to work just
fine.

Version-Release number of selected component (if applicable):

1.0.2-1.1
Comment 1 John (J5) Palmieri 2006-02-07 11:28:54 EST
Yep, all that stuff moved into pygtk so it might be a matter of changing 

import cairo.gtk 

to

import gtk.cairo

I'm checking with upstream on this.
Comment 2 John (J5) Palmieri 2006-02-07 11:42:19 EST
ok so there is no gtk.cairo and I was informed the API changed a bit.  It would
be best to mail the pygtk list with specific questions or join #pygtk on the
gimpnet irc servers.
Comment 3 John (J5) Palmieri 2006-02-07 12:09:47 EST
Ah, upstream got back to me with more specifics:

"all you need in pygtk is gtk.gdk.Window.cairo_create, the rest of the gdk/cairo
APIs are represented as methods of the returned cairo context."

Note You need to log in before you can comment on or make changes to this bug.