Bug 180375 - VMX guest auto-balloon doesn't take into account video memory
VMX guest auto-balloon doesn't take into account video memory
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 179629
  Show dependency treegraph
 
Reported: 2006-02-07 13:43 EST by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 13:48:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-02-07 13:43:03 EST
VMX guests don't cause dom0 to auto-balloon as paravirt guests do.  Probably
just needs some logic brought over to the vmx builder
Comment 1 Jeremy Katz 2006-02-07 15:31:20 EST
Hrmm, it's all common code. 
tools/python/xen/xend/XendDomainInfo.py:initDomain() is where the balloon call
occurs and then it's followed almost directly by the memory_increase_reservation.  
Comment 2 Jeremy Katz 2006-02-07 17:56:42 EST
Urk, this is caused by the device model requesting more memory to store the
video RAM in.  Bad hack committed to CVS so that we account for that when
ballooning at domain creation, but it needs a better solution for
upstream/long-term.  Filed upstream as
http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=521
Comment 5 Jeremy Katz 2006-09-05 13:48:51 EDT
A nice fix for this went upstream earlier today

Note You need to log in before you can comment on or make changes to this bug.