Bug 18040 - XMMS launch command nukes playlist!!
Summary: XMMS launch command nukes playlist!!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-01 22:43 UTC by Chris Evans
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 18:33:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Evans 2000-10-01 22:43:32 UTC
This occurs if I launch xmms from the GNOME main menu, OR if I launch xmms
from a launcher button (created from right-click on the GNOME main menu).

My loving hand-crafted playlist is nuked, and I am presented with an "Open
File" dialog.

Comment 1 Chris Evans 2000-10-02 18:30:24 UTC
Testing.. can I update this bug today?

Comment 2 Chris Evans 2000-10-02 18:33:46 UTC
Ah superb, I can.
Cause of vanishing playlist is the fact that xmms is launched with "xmms %u".
Chaning the launch command to just plain "xmms" and the problem is fixed.
However I guess the "%u" was there for a reason? If you don't have a playlist,
then the "Open File" dialog is useful to newbies, as it offers an easy entry
point.

Comment 3 Bill Nottingham 2000-10-17 04:49:57 UTC
This will be fixed in 1.2.3-2, one way or another.
It's changed to %F.

Comment 4 Chris Evans 2000-10-18 22:32:40 UTC
What is the %F supposed to do?
I changed my xmms launcher to "xmms %F" and it still wastes the
playlist and shows the file dialog.
What am I missing?

Comment 5 Bill Nottingham 2000-10-18 23:21:32 UTC
Dunno. Someone else changed the desktop entry to that. ;)

I'll have to find out.


Note You need to log in before you can comment on or make changes to this bug.