Bug 180413 - old test data for elf/check-localplt
old test data for elf/check-localplt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 18:01 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 13:12:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-02-07 18:01:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
The internal file scripts/data/localplt-i386-linux-gnu.data says that memalign is expected in the PLT of libc.so, but memalign no longer appears in the PLT of {libc.so, ld-linux.so, libm.so, libpthread.so, librt.so, libdl.so}.  The only almost-match which remains is __libc_memalign in ld-linux.so.2.

The mismatch causes elf/check-localplt to fail.  It is not immediately obvious how many following tests are skipped during an rpm rebuild.


Version-Release number of selected component (if applicable):
glibc-2.3.90-36

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -ba --target i686 glibc.spec
2.
3.
  

Actual Results:  make[2]: *** [/home/jreiser/rpmbuild/BUILD/glibc-20060204T0758/build-i686-linuxnptl/elf/check-localplt.out] Error 1
make[2]: Target `tests' not remade because of errors.
make[2]: Leaving directory `/home/jreiser/rpmbuild/BUILD/glibc-20060204T0758/elf'
make[1]: *** [elf/tests] Error 2

====================TESTING DETAILS=================
++ sed -n 's|^.*\*\*\* \[\([^]]*\.out\)\].*$|\1|p' build-i686-linuxnptl/check.log + for i in '`sed -n '\''s|^.*\*\*\* \[\([^]]*\.out\)\].*$|\1|p'\'' build-*-linux*/check.log`' + echo =====/home/jreiser/rpmbuild/BUILD/glibc-20060204T0758/build-i686-linuxnptl/elf/check-localplt.out===== =====/home/jreiser/rpmbuild/BUILD/glibc-20060204T0758/build-i686-linuxnptl/elf/check-localplt.out===== + cat /home/jreiser/rpmbuild/BUILD/glibc-20060204T0758/build-i686-linuxnptl/elf/check-localplt.out --- ../scripts/data/localplt-i386-linux-gnu.data        2006-01-11 13:06:19.000000000 -0800 +++ -   2006-02-07 14:13:27.023403000 -0800 @@ -2,6 +2,5 @@  libc.so: calloc  libc.so: free  libc.so: malloc -libc.so: memalign  libc.so: realloc
 libm.so: matherr
+ echo ============
============
+ echo ====================TESTING END=====================


Expected Results:  All tests pass.

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:03:57 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Jakub Jelinek 2006-03-15 13:12:20 EST
This is a result of fedora-branch local patch that was rejected upstream:
2005-12-20  Jakub Jelinek  <jakub@redhat.com>

        * malloc/mtrace.c (__libc_malloc, __libc_free, __libc_realloc,
        __libc_memalign): Add prototypes and libc_hidden_proto resp.
        defines for !_LIBC.
        (tr_freehook): Call __libc_free instead of free.
        (tr_mallochook): Call __libc_malloc instead of malloc.
        (tr_reallochook): Call __libc_realloc instead of realloc.
        (tr_memalignhook): Call __libc_memalign instead of memalign.
        * malloc/mcheck.c: Include stdlib.h.
        (__libc_malloc, __libc_free, __libc_realloc,
        __libc_memalign): Add prototypes and libc_hidden_proto resp.
        defines for !_LIBC.
        (freehook): Call __libc_free instead of free.
        (mallochook): Call __libc_malloc instead of malloc.
        (reallochook): Call __libc_realloc instead of realloc.
        (memalignhook): Call __libc_memalign instead of memalign.
        (mcheck): Call __libc_malloc and __libc_free instead of
        malloc and free.

Note You need to log in before you can comment on or make changes to this bug.