Bug 180432 - (ld_audit) rtdl crashes with LD_AUDIT set
rtdl crashes with LD_AUDIT set
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 22:32 EST by Joshua J. Drake
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 09:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua J. Drake 2006-02-07 22:32:17 EST
Description of problem:
ld.so crashes reading from tls when LD_AUDIT=a:b.  (even with setuid)

Version-Release number of selected component (if applicable):
glibc-2.3.x

How reproducible:
LD_AUDIT=a:b su

Steps to Reproduce:
shell$ LD_AUDIT=a:b su
  
Actual results:
ERROR: ld.so: object 'a' cannot be loaded as audit interface: cannot open shared
object file; ignored.
ERROR: ld.so: object 'b' cannot be loaded as audit interface: cannot open shared
object file; ignored.
Segmentation fault


Expected results:
Password:

Additional info:
seems to be some sort of null deref reading from an address retrieved from TLS.
Comment 1 Ulrich Drepper 2006-04-30 19:01:06 EDT
Works at least in rawhide.
Comment 2 Joshua J. Drake 2007-06-17 20:12:07 EDT
this bug creeped back in at some point.. FC6 is affected for sure.  
Comment 4 Jakub Jelinek 2007-06-28 06:02:21 EDT
Please try glibc-2.5-17.fc6 in fc6 testing updates.
Comment 5 Jakub Jelinek 2007-07-19 09:25:50 EDT
glibc-2.5-18.fc6 has been pushed as FC6 update some time ago.

Note You need to log in before you can comment on or make changes to this bug.