Bug 180438 - Installer unable to remove gcj packages on RHEL4 U2 "Everything" install
Installer unable to remove gcj packages on RHEL4 U2 "Everything" install
Status: CLOSED DUPLICATE of bug 192268
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
400
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Vlady Zlatkin
:
Depends On:
Blocks: 171660
  Show dependency treegraph
 
Reported: 2006-02-07 23:09 EST by Thomas Cameron
Modified: 2007-07-31 11:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 11:24:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Cameron 2006-02-07 23:09:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060130 Red Hat/1.0.7-1.4.3 Firefox/1.0.7

Description of problem:
I did an "everything" install of RHEL 4 U2 on an i386 machine.  I then ran up2date -u to get it up to date.  When I ran install.sh, I got this:

** Removing gcj packages (if applicable).
error: Failed dependencies:
        gcc-java >= 3.4 is needed by (installed) katana-build-2.0.0-1.noarch
        java-1.4.2-gcj-compat = 0:1.4.2.0-27jpp is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-27jpp.noarch
        ecj is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-27jpp.noarch

**** pre-installation
*** updates script SKIPPED!

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install RHEL4 U2 "Everything"
2. Run install.sh

Actual Results:  ** Removing gcj packages (if applicable).
error: Failed dependencies:
        gcc-java >= 3.4 is needed by (installed) katana-build-2.0.0-1.noarch
        java-1.4.2-gcj-compat = 0:1.4.2.0-27jpp is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-27jpp.noarch
        ecj is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-27jpp.noarch

**** pre-installation
*** updates script SKIPPED!

Expected Results:  I should have uninstalled appropriate packages

Additional info:
Comment 2 Mike McCune 2006-06-14 11:24:36 EDT
In the new version of the installer we still require that the system be @Base. 
It does do its best to remove conflicting packages but sometimes it can't
resolve all the issues.

In:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192268

we do include a verbose error message:

"Could not install RHN packages.  Most likely your system is not configured with
the @Base package group.  See the RHN Satellite Server Installation Guide for
more information about Software Requirements."





*** This bug has been marked as a duplicate of 192268 ***

Note You need to log in before you can comment on or make changes to this bug.