Bug 180463 - rmmod pl2303 triggers kernel bug
rmmod pl2303 triggers kernel bug
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-02-08 04:23 EST by Kris Buytaert
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-24 16:32:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The actual oops (6.67 KB, text/plain)
2006-02-08 04:25 EST, Kris Buytaert
no flags Details
Test fix #1 - wait until scheduled work completes in disconnect (424 bytes, patch)
2006-05-23 00:32 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Kris Buytaert 2006-02-08 04:23:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
My USB serial port didn't work , upon closer inspection I noticed 

pl2303 4-3.2:1.0: pl2303 converter detected
usb 4-3.2: pl2303 converter now attached to ttyUSB0
usbcore: registered new driver pl2303
drivers/usb/serial/pl2303.c: Prolific PL2303 USB to serial adaptor driver
 then some lines later 

pl2303 ttyUSB0: pl2303_open - failed submitting interrupt urb, error -28

So I tried a rmmod pl2303 which resulted in a crah

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1. rmmod pl2303

Actual Results:  Kernel bug ..  oops is attached

Expected Results:  the module to be removed , or a working pl2303 driver :)

Additional info:
Comment 1 Kris Buytaert 2006-02-08 04:25:06 EST
Created attachment 124364 [details]
The actual oops

this is the actual oops I got.

My machine started a (2 minute ?) countdown, then contuinued working .. 
(except for the serial adapter ..)
Comment 2 Greg Kroah-Hartman 2006-02-10 02:25:51 EST
Are you plugging the pl2303 device into a USB 2.0 hub, or into the main port
on the motherboard?

And did you have a program that was accessing the pl2303 device when you 
unloaded it?

Can you attach the /proc/bus/usb/devices file with the pl2303 device plugged
Comment 3 Kris Buytaert 2006-02-10 03:32:58 EST
Plugged in to a hub actually.

No program was accessing it.. I tried starting minicom but that failed.

I`ll provide you with the devices file on monday .
Comment 4 Greg Kroah-Hartman 2006-02-10 03:48:45 EST
If you plug it into a usb 1.1 hub, or into the main usb port on the machine, 
odds are it will work just fine.
Comment 5 Kris Buytaert 2006-02-10 05:54:51 EST
It used to be working trough the hub till I upgraded to FC5 Testing.  I`ll test
on monday :)
Comment 6 Kris Buytaert 2006-02-13 03:58:40 EST
It indeed works when plugging it in the machine directly.  However as mentionned
before, this used to work before.
Comment 7 Greg Kroah-Hartman 2006-02-13 15:55:55 EST
You got lucky before.  This is one area of the USB stack, where Linux is not
fully operational (usb 1.1 devices plugged into 2.0 hubs.)  People are still
working on this, and it looks like the 2.6.16 kernel will be a lot better
(I can't duplicate this anymore on my boxes), but it is still not fully 

Comment 8 Pete Zaitcev 2006-05-17 22:26:43 EDT
Kris, how is 2.6.16-1.2111_FC5?
Comment 9 Kris Buytaert 2006-05-19 03:43:11 EDT
Linux mine2.x-tend.be 2.6.16-1.2088_FC6

Tried and crashed again .. will try with the version you suggested.. also
got to upgrade fist :)
Comment 10 Pete Zaitcev 2006-05-22 15:58:31 EDT
See also:
Comment 11 Pete Zaitcev 2006-05-23 00:32:27 EDT
Created attachment 129839 [details]
Test fix #1 - wait until scheduled work completes in disconnect
Comment 12 Dave Jones 2006-10-16 17:05:24 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 13 Kris Buytaert 2006-11-23 07:25:03 EST
Seems to be solved in  2.6.18-1.2849.fc6

Note You need to log in before you can comment on or make changes to this bug.