Bug 180468 - KDE applications crash on exit since 3.5.1
KDE applications crash on exit since 3.5.1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: scim-qtimm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 05:47 EST by Julian Sikorski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 14:57:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2006-02-08 05:47:37 EST
Hi. I have noticed this behaviour since upgrading to KDE 3.5.1 via yum. I am
running an up-to-date installation. Gnome applications work fine, whereas kde
(or QT) ones crash on exit sending signal 6 (SIGABRT). This is quite
frustrating. I have noticed this at least for konsole, kwrite, kxmame and
konqureror. Here is the backtrace:

======= Backtrace: =========
/lib/libc.so.6[0x174124]
/lib/libc.so.6(__libc_free+0x77)[0x17465f]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0xdaa0a9]
/usr/lib/scim-1.0/1.4.0/Config/socket.so(_ZN9__gnu_cxx10__mt_allocISsNS_20__common_pool_policyINS_6__poolELb1EEEE10deallocateEPSsj+0x40)[0xff7e8a]
/usr/lib/scim-1.0/1.4.0/IMEngine/socket.so(_ZN4scim20SocketIMEngineGlobalD1Ev+0x98)[0x53de60]
/usr/lib/scim-1.0/1.4.0/IMEngine/socket.so(socket_LTX_scim_module_exit+0x25)[0x53e0df]
/usr/lib/libscim-1.0.so.8(_ZN4scim6Module6unloadEv+0x40)[0xa03e9e]
/usr/lib/libscim-1.0.so.8(_ZN4scim6ModuleD1Ev+0x1f)[0xa04287]
/usr/lib/libscim-1.0.so.8(_ZN4scim13CommonBackEndD0Ev+0x49)[0x9c39c9]
/usr/lib/libscim-1.0.so.8(_ZN4scim16ReferencedObject5unrefEv+0x20)[0xa07764]
/usr/lib/qt-3.3/plugins/inputmethods/libqscim.so(_ZN4scim23QScimInputContextGlobal8finalizeEv+0x1a4)[0x2ac8e4]
/usr/lib/qt-3.3/plugins/inputmethods/libqscim.so[0x2b51ad]
/lib/libc.so.6(exit+0xc5)[0x13bba9]
/lib/libc.so.6(__libc_start_main+0xe7)[0x125d67]
kwrite[0x80483e1]
======= Memory map: ========
00111000-00234000 r-xp 00000000 03:05 1826372    /lib/libc-2.3.5.so
00234000-00236000 r-xp 00123000 03:05 1826372    /lib/libc-2.3.5.so
00236000-00238000 rwxp 00125000 03:05 1826372    /lib/libc-2.3.5.so
00238000-0023a000 rwxp 00238000 00:00 0
0023a000-00240000 r-xp 00000000 03:05 1339225    /usr/lib/libfam.so.0.0.0
00240000-00241000 rwxp 00006000 03:05 1339225    /usr/lib/libfam.so.0.0.0
00241000-00256000 r-xp 00000000 03:05 1339214    /usr/lib/libart_lgpl_2.so.2.3.17
00256000-00257000 rwxp 00014000 03:05 1339214    /usr/lib/libart_lgpl_2.so.2.3.17
00257000-00275000 r-xp 00000000 03:05 1339189    /usr/lib/libjpeg.so.62.0.0
00275000-00276000 rwxp 0001d000 03:05 1339189    /usr/lib/libjpeg.so.62.0.0
00276000-00287000 r-xp 00000000 03:05 1826175    /lib/libpcre.so.0.0.1
00287000-00288000 rwxp 00010000 03:05 1826175    /lib/libpcre.so.0.0.1
00288000-00291000 r-xp 00000000 03:05 1826590    /lib/libnss_files-2.3.5.so
00291000-00292000 r-xp 00008000 03:05 1826590    /lib/libnss_files-2.3.5.so
00292000-00293000 rwxp 00009000 03:05 1826590    /lib/libnss_files-2.3.5.so
00293000-002be000 r-xp 00000000 03:05 1695896   
/usr/lib/qt-3.3/plugins/inputmethods/libqscim.so
002be000-002bf000 rwxp 0002b000 03:05 1695896   
/usr/lib/qt-3.3/plugins/inputmethods/libqscim.so
002c3000-002c6000 r-xp 00000000 03:05 1826329    /lib/libattr.so.1.1.0
002c6000-002c7000 rwxp 00002000 03:05 1826329    /lib/libattr.so.1.1.0
002c9000-002cf000 r-xp 00000000 03:05 1826421    /lib/libacl.so.1.1.0
002cf000-002d0000 rwxp 00005000 03:05 1826421    /lib/libacl.so.1.1.0
002d0000-002f5000 r-xp 00000000 03:05 1702798   
/usr/lib/qt-3.3/plugins/inputmethods/libqsimple.so
002f5000-002f6000 rwxp 00024000 03:05 1702798   
/usr/lib/qt-3.3/plugins/inputmethods/libqsimple.so
002f6000-00301000 r-xp 00000000 03:05 1702800   
/usr/lib/qt-3.3/plugins/inputmethods/libqxim.so
00301000-00302000 rwxp 0000a000 03:05 1702800   
/usr/lib/qt-3.3/plugins/inputmethods/libqxim.so
00311000-003e1000 r-xp 00000000 03:05 1340051    /usr/X11R6/lib/libX11.so.6.2
003e1000-003e5000 rwxp 000cf000 03:05 1340051    /usr/X11R6/lib/libX11.so.6.2
003e7000-004bd000 r-xp 00000000 03:05 1340653    /usr/lib/libkdeprint.so.4.2.0
004bd000-004c5000 rwxp 000d6000 03:05 1340653    /usr/lib/libkdeprint.so.4.2.0
004c7000-0052d000 r-xp 00000000 03:05 1349105    /usr/lib/libkutils.so.1.2.0
0052d000-00533000 rwxp 00065000 03:05 1349105    /usr/lib/libkutils.so.1.2.0
00533000-00547000 r-xp 00000000 03:05 1439866   
/usr/lib/scim-1.0/1.4.0/IMEngine/socket.so
00547000-00548000 rwxp 00013000 03:05 1439866   
/usr/lib/scim-1.0/1.4.0/IMEngine/socket.so
00551000-00552000 r-xp 00000000 03:05 1436330   
/usr/X11R6/lib/X11/locale/lib/common/xlcUTF8Load.so.2
00552000-00553000 rwxp 00000000 03:05 1436330   
/usr/X11R6/lib/X11/locale/lib/common/xlcUTF8Load.so.2
00554000-00558000 r-xp 00000000 03:05 1702736   
/usr/lib/qt-3.3/plugins/inputmethods/libqimsw-none.so
00558000KCrash: Application 'kwrite' crashing...

I am using pl_PL.UTF-8 locale, with the following ~/.xinput.d/pl_PL:

XIM=SCIM
XIM_PROGRAM=scim
XIM_ARGS="-d"
GTK_IM_MODULE=scim


SCIM_QTIMM_XINPUT=/etc/X11/xinit/xinput.d/scim-qtimm
[ -r "${SCIM_QTIMM_XINPUT}" ] && . ${SCIM_QTIMM_XINPUT}
unset SCIM_QTIMM_XINPUT

Am I doing something wrong? Greets.
Comment 1 Julian Sikorski 2006-03-22 14:57:58 EST
I am no longer able to reproduce this bug since I have upgraded to Fedora Core
5. Works fine here, apart from the fact that QT IM module does not work.
Comment 2 Jens Petersen 2006-03-22 21:38:13 EST
Note however that fc5 default to XIM under kde/qt apps not scim-qtimm
because of bug 182177.  We want to address that for FC6.

Note You need to log in before you can comment on or make changes to this bug.