Bug 180473 - Printing fails on eplaser because foomatic-gswrapper select wrong OutputFile
Printing fails on eplaser because foomatic-gswrapper select wrong OutputFile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 07:44 EST by Mathias Nicolajsen Kjærgaard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 04:22:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug output in /var/log/cups/error_log (1.83 KB, text/plain)
2006-02-08 07:46 EST, Mathias Nicolajsen Kjærgaard
no flags Details
Patch that fixes the problem (906 bytes, patch)
2006-02-08 07:54 EST, Mathias Nicolajsen Kjærgaard
no flags Details | Diff

  None (edit)
Description Mathias Nicolajsen Kjærgaard 2006-02-08 07:44:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
Printing to a eplaser printer (Epson AcuLaser C1900) fails because foomatic-gswrapper selects "| cat >&3" as outputfile instead of "/dev/fd/3".

"| cat >&3" is selected because "test -e /dev/fd/3" returns false. I do not know why, since "ls -la /dev/fd/" returns:

dr-x------  2 root root  0 Feb  8 13:43 .
dr-xr-xr-x  5 root root  0 Feb  8 13:43 ..
lrwx------  1 root root 64 Feb  8 13:43 0 -> /dev/pts/2
lrwx------  1 root root 64 Feb  8 13:43 1 -> /dev/pts/2
lrwx------  1 root root 64 Feb  8 13:43 2 -> /dev/pts/2
lr-x------  1 root root 64 Feb  8 13:43 3 -> /proc/7188/fd

and if the attached patch is applied, printing works.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-19.2

How reproducible:
Always

Steps to Reproduce:
1. By an Epson AcuLaser C1900
2. Configure the printer
3. Print a test-page
  

Additional info:
Comment 1 Mathias Nicolajsen Kjærgaard 2006-02-08 07:46:14 EST
Created attachment 124376 [details]
Debug output in /var/log/cups/error_log
Comment 2 Mathias Nicolajsen Kjærgaard 2006-02-08 07:54:05 EST
Created attachment 124377 [details]
Patch that fixes the problem

I do not know if this is the correct way to fix the problem, but it works for
me.
Comment 3 Mathias Nicolajsen Kjærgaard 2006-02-08 07:56:45 EST
The problem is also described in the User Notes here:
http://www.linuxprinting.org/show_printer.cgi?recnum=Epson-AcuLaser_C1900
Comment 4 Tim Waugh 2006-02-08 09:43:49 EST
Weird.  I don't understand why that would be the case. :-/
Comment 5 Mathias Nicolajsen Kjærgaard 2006-02-13 01:33:25 EST
It seems the bug has already been solved i FC5-test2(With a similar change of
foomatic-gswrapper). For me it is OK to close the bug.
I am sorry it did not check FC5 before reporting.

Note You need to log in before you can comment on or make changes to this bug.