Bug 1804796 - Missing files from package tzdata
Summary: Missing files from package tzdata
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel7-atomic-container
Version: 7.7
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Bohdan Khomutskyi
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 16:18 UTC by Jarle Bjørgeengen
Modified: 2021-06-24 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-24 16:56:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jarle Bjørgeengen 2020-02-19 16:18:11 UTC
Description of problem:

Files from package tzdata is missing even though package is installed. 

Version-Release number of selected component (if applicable):


How reproducible:

Always (today :-)) 

Steps to Reproduce:
1. 

podman run -ti registry.redhat.io/rhel7-atomic:latest

2.
bash-4.2# for i in `rpm -ql tzdata` ; do stat $i; done 2>&1 |head 
stat: cannot stat '/usr/share/doc/tzdata-2019c': No such file or directory
stat: cannot stat '/usr/share/doc/tzdata-2019c/README': No such file or directory
stat: cannot stat '/usr/share/doc/tzdata-2019c/theory.html': No such file or directory
stat: cannot stat '/usr/share/doc/tzdata-2019c/tz-art.html': No such file or directory
stat: cannot stat '/usr/share/doc/tzdata-2019c/tz-link.html': No such file or directory
stat: cannot stat '/usr/share/zoneinfo': No such file or directory
stat: cannot stat '/usr/share/zoneinfo/Africa': No such file or directory
stat: cannot stat '/usr/share/zoneinfo/Africa/Abidjan': No such file or directory
stat: cannot stat '/usr/share/zoneinfo/Africa/Accra': No such file or directory
stat: cannot stat '/usr/share/zoneinfo/Africa/Addis_Ababa': No such file or directory
..... and so on
3.

Actual results:

rpm inventory does not reflect actual inventory

Expected results:

rpm inventory does  reflect actual inventory

Additional info:

Comment 7 Bohdan Khomutskyi 2021-06-24 16:56:01 UTC
Hello Jarle Bjørgeengen,
 
It is expected that some files, including package documentation, and in this case, timezone information, are not present in the rhel7-atomic container image. Those files are intentionally removed from the image in order to minimize it's size. This is not a bug.

In case you need all files of tzdata in rhel7-atomic container, you can apply the following solution.

# Remove tzdata package from rhel7-atomic-container
rpm --nodeps -e tzdata

# Install tzdata package
microdnf --enablerepo=rhel-7-server-rpms install tzdata

After tzdata installation, you will be able to access all files of the RPM.


With best regards,
Bohdan Khomutskyi
Software Engineer
Enterprise Experience and Delivery
Red Hat


Note You need to log in before you can comment on or make changes to this bug.