Bug 1804895 - gtester is deprecated in Fedora 31
Summary: gtester is deprecated in Fedora 31
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Restraint
Classification: Retired
Component: general
Version: master
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Rodríguez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 20:10 UTC by Daniel Rodríguez
Modified: 2020-03-10 14:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 14:42:27 UTC


Attachments (Terms of Use)

Description Daniel Rodríguez 2020-02-19 20:10:22 UTC
Description of problem:

(gtester:409): WARNING **: 17:46:53.279: Deprecated: Since GLib 2.62, gtester and gtester-report are deprecated. Port to TAP.

And the deprecation warning will make it abort execution if warnings are made fatal.

It's suggested to use TAP instead [0]. Also, is mentioned in glib docs [1]:

 If you are using Autotools, you're strongly encouraged to use the Automake 
 TAP harness; GLib provides template files for easily integrating with it:

 glib-tap.mk
 tap-test
 tap-driver.sh

[0] https://www.gnu.org/software/automake/manual/html_node/Using-the-TAP-test-protocol.html
[1] https://developer.gnome.org/glib/stable/glib-Testing.html

Version-Release number of selected component (if applicable):

Since GLib 2.62

How reproducible:

All the time.

Steps to Reproduce:
1. Run test with gtester using the --g-fatal-warnings or setting G_DEBUG="fatal_warnings"
2. Pause for a minute and reflect

Actual results:

gtester aborts itself due to deprecation warning made fatal

Expected results:

Deprecation warning doesn't make gtester abort.

Additional info:

Removing fatal_warnings from G_DEBUG works.


Note You need to log in before you can comment on or make changes to this bug.