Bug 1805148 - Job for implicitclass backend fails with "No destination host name supplied by cups-browsed for printer ..., is cups-browsed running?"
Summary: Job for implicitclass backend fails with "No destination host name supplied b...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cups-filters
Version: 30
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 11:26 UTC by Attila
Modified: 2020-03-02 07:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-02 07:43:25 UTC
Type: Bug


Attachments (Terms of Use)
cups queue (66.22 KB, image/png)
2020-02-20 11:26 UTC, Attila
no flags Details
cups job log (30.87 KB, text/plain)
2020-02-27 09:36 UTC, Guillaume Brocker
no flags Details

Description Attila 2020-02-20 11:26:56 UTC
Created attachment 1664328 [details]
cups queue

Description of problem:
I did an update from cups-filters-1.22.5-1.fc30.x86_64.rpm to cups-filters-1.27.0-1.fc30.x86_64.rpm. Since then I can not print. It doesn't matter which printer I choose to print to.

Version-Release number of selected component (if applicable):
cups-filters-1.27.0-1.fc30.x86_64.rpm

How reproducible:
always

Steps to Reproduce:
1. dnf update
2. open a document of your choice
3. print

Actual results:
printer stopped. No destionation host name supplied by cups-browsed for printer ..., is cups-browsed running?

Comment 1 Zdenek Dohnal 2020-02-24 15:13:52 UTC
Hi Attila,

thank you for reporting the issue!

Would you mind following the steps in https://fedoraproject.org/wiki/How_to_debug_printing_problems#How_to_get_and_attach_logs_for_bug_report ?

I need the job log when cups debug logging is turned on. Your queue will be paused now - so you will need cancel the jobs ('cancel -a'), reenable the queue (sudo cupsenable <name>), restart cups-browsed and wait till all your print queues appear.

The issue probably is a known race condition mentioned here https://github.com/OpenPrinting/cups-filters/issues/163#issuecomment-561692069 - two new directives were introduced for mitigation - please try to play a little with them to suit your needs.

Comment 2 Attila 2020-02-26 11:59:59 UTC
Hi,

sorry for my late reply. In the meantime I have upgraded the server on which the service cupsd is running. There was cups-filters-1.20 installed. Perhaps it wasn't compatible to cups-filters-1.27 on the client side and caused the issue.
Now it works again. You can close this bug report.
Anyway thank you for your efforts.

Comment 3 Zdenek Dohnal 2020-02-26 12:06:09 UTC
Ok, if it is okay with you, I'll close the ticket.

The bottom line - the current upstream solution is two directives which mitigate the issue - please see link in comment 1.

Comment 4 Guillaume Brocker 2020-02-26 12:20:58 UTC
Hi,

Sorry for my late comment. I'm having the same issue on Fedora 31. I have a network printer that is configured on my workstation's cups server. So I'm not getting through another server for printing.

Since it is on F31, and not F30, shoud I open a new bug for that ?

Comment 5 Zdenek Dohnal 2020-02-26 12:31:41 UTC
No need, I'll reopen the bug (cups-filters is the same version - or it will be, at least).

Would you mind providing info requested in comment #1? Did you try shuffling with values of those directives?

Comment 6 Guillaume Brocker 2020-02-27 09:36:50 UTC
Created attachment 1666157 [details]
cups job log

Hi,

So here is the log of a job that doesn't print.

I discovered something new. THe bug occurs only when printing given pages of a document. Printing the whole document works fine.

Comment 7 Zdenek Dohnal 2020-02-28 05:27:15 UTC
Hi Guillaume,

thank you for the logs!

Are you sure the logs are from affected job? Because I don't see Attila's message in the log and you don't even use implicitclass backend. (based on you said you have the same issue as Attila).

There is different bug raised by rebase - https://bugzilla.redhat.com/show_bug.cgi?id=1806862 and if you didn't have the same issue as Attila, this one can be it.

Comment 8 Guillaume Brocker 2020-02-28 07:53:01 UTC
(In reply to Zdenek Dohnal from comment #7)
> There is different bug raised by rebase -
> https://bugzilla.redhat.com/show_bug.cgi?id=1806862 and if you didn't have
> the same issue as Attila, this one can be it.

Hi,

In deed, the bug you mentionned is the one I have on my computer too. So I think you can close this one now. Thank you for your help !


Note You need to log in before you can comment on or make changes to this bug.