Bug 1805460 - To install virt-who on satellite or client connected to satellite does require RHEL base repository access not satellite tools
Summary: To install virt-who on satellite or client connected to satellite does requir...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Virt-who Configure Plugin
Version: 6.7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Kunxin Huang
satellite-doc-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 20:12 UTC by Ganesh Payelkar
Modified: 2020-07-26 01:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)
screenshot of virt-who configuration page (55.83 KB, image/png)
2020-02-20 20:34 UTC, Ganesh Payelkar
no flags Details

Description Ganesh Payelkar 2020-02-20 20:12:11 UTC
Description of problem:

To install virt-who on satellite or client connected to satellite does require RHEL base repository access, not satellite tools

Version-Release number of selected component (if applicable):
satellite-6.7.0-5.beta.el7sat.noarch

How reproducible:
New installation 

Steps to Reproduce:
1. Install satellite 6.7 Beta 
2. configure Virt-who through WebUI
3. WebUI --> Infrastructure --> Virt-who Configurations --> Create config --> Submit Details 
   This will redirect you to the overview and Deploy page, where you can find below details on-page. 

Actual results:


Use either hammer command or the script below to deploy this configuration. Both require root privileges. Run one of them on the target host which has access to Red Hat Satellite Tools repository and will run virt-who reporting, preferably Satellite host:


Expected results:

Instead "Satellite Tools" should be RHEL OS Base repository access.


Additional info:


# yum install virt-who -y
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package virt-who.noarch 0:0.24.7-1.el7 will be installed
--> Processing Dependency: systemd-python for package: virt-who-0.24.7-1.el7.noarch
--> Processing Dependency: python-suds for package: virt-who-0.24.7-1.el7.noarch
--> Processing Dependency: libvirt-python for package: virt-who-0.24.7-1.el7.noarch
--> Running transaction check
---> Package libvirt-python.x86_64 0:4.5.0-1.el7 will be installed
---> Package python-suds.noarch 0:0.4.1-5.el7 will be installed
---> Package systemd-python.x86_64 0:219-67.el7_7.3 will be installed
--> Processing Dependency: systemd-libs = 219-67.el7_7.3 for package: systemd-python-219-67.el7_7.3.x86_64
--> Processing Dependency: systemd = 219-67.el7_7.3 for package: systemd-python-219-67.el7_7.3.x86_64
--> Running transaction check
---> Package systemd.x86_64 0:219-67.el7_7.2 will be updated
--> Processing Dependency: systemd = 219-67.el7_7.2 for package: systemd-sysv-219-67.el7_7.2.x86_64
---> Package systemd.x86_64 0:219-67.el7_7.3 will be an update
---> Package systemd-libs.x86_64 0:219-67.el7_7.2 will be updated
--> Processing Dependency: systemd-libs = 219-67.el7_7.2 for package: libgudev1-219-67.el7_7.2.x86_64
---> Package systemd-libs.x86_64 0:219-67.el7_7.3 will be an update
--> Running transaction check
---> Package libgudev1.x86_64 0:219-67.el7_7.2 will be updated
---> Package libgudev1.x86_64 0:219-67.el7_7.3 will be an update
---> Package systemd-sysv.x86_64 0:219-67.el7_7.2 will be updated
---> Package systemd-sysv.x86_64 0:219-67.el7_7.3 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                             Arch                                        Version                                             Repository                                               Size
===================================================================================================================================================================================================================
Installing:
 virt-who                                            noarch                                      0.24.7-1.el7                                        rhel-7-server-rpms                                      248 k
Installing for dependencies:
 libvirt-python                                      x86_64                                      4.5.0-1.el7                                         rhel-7-server-rpms                                      343 k
 python-suds                                         noarch                                      0.4.1-5.el7                                         rhel-7-server-rpms                                      204 k
 systemd-python                                      x86_64                                      219-67.el7_7.3                                      rhel-7-server-rpms                                      137 k
Updating for dependencies:
 libgudev1                                           x86_64                                      219-67.el7_7.3                                      rhel-7-server-rpms                                      101 k
 systemd                                             x86_64                                      219-67.el7_7.3                                      rhel-7-server-rpms                                      5.1 M
 systemd-libs                                        x86_64                                      219-67.el7_7.3                                      rhel-7-server-rpms                                      411 k
 systemd-sysv                                        x86_64                                      219-67.el7_7.3                                      rhel-7-server-rpms                                       89 k

Transaction Summary
===================================================================================================================================================================================================================
Install  1 Package  (+3 Dependent packages)
Upgrade             ( 4 Dependent packages)

Total download size: 6.6 M
Downloading packages:
No Presto metadata available for rhel-7-server-rpms
(1/8): libgudev1-219-67.el7_7.3.x86_64.rpm                                                                                                                                                  | 101 kB  00:00:00     
(2/8): python-suds-0.4.1-5.el7.noarch.rpm                                                                                                                                                   | 204 kB  00:00:00     
(3/8): libvirt-python-4.5.0-1.el7.x86_64.rpm                                                                                                                                                | 343 kB  00:00:00     
(4/8): systemd-libs-219-67.el7_7.3.x86_64.rpm                                                                                                                                               | 411 kB  00:00:00     
(5/8): systemd-python-219-67.el7_7.3.x86_64.rpm                                                                                                                                             | 137 kB  00:00:00     
(6/8): systemd-sysv-219-67.el7_7.3.x86_64.rpm                                                                                                                                               |  89 kB  00:00:00     
(7/8): systemd-219-67.el7_7.3.x86_64.rpm                                                                                                                                                    | 5.1 MB  00:00:00     
(8/8): virt-who-0.24.7-1.el7.noarch.rpm                                                                                                                                                     | 248 kB  00:00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                               22 MB/s | 6.6 MB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : systemd-libs-219-67.el7_7.3.x86_64                                                                                                                                                             1/12 
  Updating   : systemd-219-67.el7_7.3.x86_64                                                                                                                                                                  2/12 
  Installing : systemd-python-219-67.el7_7.3.x86_64                                                                                                                                                           3/12 
  Installing : python-suds-0.4.1-5.el7.noarch                                                                                                                                                                 4/12 
  Installing : libvirt-python-4.5.0-1.el7.x86_64                                                                                                                                                              5/12 
  Installing : virt-who-0.24.7-1.el7.noarch                                                                                                                                                                   6/12 
  Updating   : systemd-sysv-219-67.el7_7.3.x86_64                                                                                                                                                             7/12 
  Updating   : libgudev1-219-67.el7_7.3.x86_64                                                                                                                                                                8/12 
  Cleanup    : systemd-sysv-219-67.el7_7.2.x86_64                                                                                                                                                             9/12 
  Cleanup    : systemd-219-67.el7_7.2.x86_64                                                                                                                                                                 10/12 
  Cleanup    : libgudev1-219-67.el7_7.2.x86_64                                                                                                                                                               11/12 
  Cleanup    : systemd-libs-219-67.el7_7.2.x86_64                                                                                                                                                            12/12 
  Verifying  : systemd-libs-219-67.el7_7.3.x86_64                                                                                                                                                             1/12 
  Verifying  : systemd-219-67.el7_7.3.x86_64                                                                                                                                                                  2/12 
  Verifying  : libvirt-python-4.5.0-1.el7.x86_64                                                                                                                                                              3/12 
  Verifying  : libgudev1-219-67.el7_7.3.x86_64                                                                                                                                                                4/12 
  Verifying  : systemd-sysv-219-67.el7_7.3.x86_64                                                                                                                                                             5/12 
  Verifying  : systemd-python-219-67.el7_7.3.x86_64                                                                                                                                                           6/12 
  Verifying  : virt-who-0.24.7-1.el7.noarch                                                                                                                                                                   7/12 
  Verifying  : python-suds-0.4.1-5.el7.noarch                                                                                                                                                                 8/12 
  Verifying  : libgudev1-219-67.el7_7.2.x86_64                                                                                                                                                                9/12 
  Verifying  : systemd-sysv-219-67.el7_7.2.x86_64                                                                                                                                                            10/12 
  Verifying  : systemd-libs-219-67.el7_7.2.x86_64                                                                                                                                                            11/12 
  Verifying  : systemd-219-67.el7_7.2.x86_64                                                                                                                                                                 12/12 

Installed:
  virt-who.noarch 0:0.24.7-1.el7                                                                                                                                                                                   

Dependency Installed:
  libvirt-python.x86_64 0:4.5.0-1.el7                                   python-suds.noarch 0:0.4.1-5.el7                                   systemd-python.x86_64 0:219-67.el7_7.3                                  

Dependency Updated:
  libgudev1.x86_64 0:219-67.el7_7.3                  systemd.x86_64 0:219-67.el7_7.3                  systemd-libs.x86_64 0:219-67.el7_7.3                  systemd-sysv.x86_64 0:219-67.el7_7.3                 

Complete!

Comment 3 Ganesh Payelkar 2020-02-20 20:34:11 UTC
Created attachment 1664490 [details]
screenshot of virt-who configuration page


Note You need to log in before you can comment on or make changes to this bug.