Bug 18057 - RPM -qf broken
RPM -qf broken
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 02:10 EDT by Chris Yeo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 02:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Yeo 2000-10-02 02:10:29 EDT
When rpm -qf is run with an arguement that includes a file like ./testfile 
you get an unexpected result:

root@chris:[ /etc/sane.d ] rpm -qf ./apple.conf   
file /apple.conf: No such file or directory

And from a 'strace' it is actually trying to access the file /apple.conf

access("/apple.conf", F_OK)             = -1 ENOENT (No such file or 
directory)

Thanks

Chris
Comment 1 Jeff Johnson 2000-10-03 13:11:41 EDT
The following works for me
	bash $cd /bin
	bash$ rpm -qf ./rpm
	rpm-4.0.1-0.5
Comment 2 Chris Yeo 2000-10-03 20:02:03 EDT
I think that this is easiest explained by using a 'newer' version of RPM than I
have.  Is that the version that comes on the ISO's?

cyeo@chris:[ /bin ] rpm -qf /bin/rpm
rpm-4.0-4

Note You need to log in before you can comment on or make changes to this bug.