Bug 180570 - pilot-link needs to be upgraded to stable version
pilot-link needs to be upgraded to stable version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
http://fedoraproject.org/wiki/DocsPro...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 20:39 EST by tmoore7773
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 12:16:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tmoore7773 2006-02-08 20:39:07 EST
pilot-link needs to be the stable version not the
"pre" version

Version of release notes this bug refers to:
Fedora Core 4 final release

As reported, when I backed out kdepim, evolution, jpilot, ...
rpm -e pilot-link,
went to fedora core 3
got 
pilot-link-0.11.8-8.src.rpm

did an 
rpmbuild --rebuild pilot-link-0.11.8-8.src.rpm
reinstalled the pilot-link rpm from
/usr/src/redhat/RPMS/i386/pilot-link-0.11.8-8.i386.rpm

had to rpmbuild --rebuild
kdepim, evolution, jpilot
and whatever else complained when I did the
rpm -e pilot-link

It all worked.  It is not a kernel problem.
The problem is using the pilot-link-0.12*pre*rpm.
It has a new API which breaks the visor and palm rpm

The new kernel still does not automagically recognize
the visor in time so I have to do the

if [ ! -c /dev/ttyUSB0 ] ; then
        mknod /dev/ttyUSB0 c 188 0
fi
if [ ! -c /dev/ttyUSB1 ] ; then
        mknod /dev/ttyUSB1 c 188 1
fi
if [ ! -L /dev/pilot ] ; then
        ln -s /dev/ttyUSB1 /dev/pilot
fi

chown [yourname]  /dev/ttyUSB0 /dev/ttyUSB1
chmod 0664 /dev/ttyUSB0 /dev/ttyUSB1

kabooki dance.
Comment 1 Ngo Than 2006-04-14 12:16:24 EDT
i have reverted to stable release 0.11.8. It's now available in
fc4-update-testing. Many thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.