Bug 180642 - Need sub-package ant-commons-net
Need sub-package ant-commons-net
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
Depends On:
  Show dependency treegraph
Reported: 2006-02-09 12:26 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-20 11:09:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2006-02-09 12:26:47 EST
Description of problem:
Eclipse includes ant-commons-net.  We symlink against our system jars for
everything we ship.  ant-commons-net is the only exception.  It would be nice if
we could ship it.

Version-Release number of selected component (if applicable):
Comment 1 Ben Konrath 2006-06-01 18:56:27 EDT
Eclipse 3.2 also needs these ant plugins: ant-icontract.jar, ant-jai.jar,
ant-jmf.jar, ant-netrexx.jar, ant-starteam.jar, ant-stylebook.jar, ant-vaj.jar,
ant-weblogic.jar, ant-xalan1.jar, ant-xslp.jar

We are currently deleting them.
Comment 2 Andrew Overholt 2006-12-05 15:58:28 EST
ant-apache-bsf is another necessity.
Comment 3 David Walluck 2007-03-14 19:26:32 EDT
With ant 1.7.0, all of the jars mentioned in comment #1 have gone away.

There still doesn't seem to be a reason why Fedora does not have
jakarta-commons-net or bsf, as these two packages are definitely buildable on a
free stack.
Comment 4 Permaine Cheung 2007-09-20 11:09:57 EDT
We now have ant 1.7.0 in Fedora with the ant-apache-bsf and ant-commons-net

Note You need to log in before you can comment on or make changes to this bug.