Bug 1806466 - gcc-10.0.1-0.8.fc33: internal compiler error: in propagate_vals_across_arith_jfunc, at ipa-cp.c:2039
Summary: gcc-10.0.1-0.8.fc33: internal compiler error: in propagate_vals_across_arith_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 09:39 UTC by Petr Pisar
Modified: 2020-10-05 08:30 UTC (History)
11 users (show)

Fixed In Version: gcc-10.0.1-0.9.fc33 gcc-10.0.1-0.9.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-16 20:39:08 UTC
Type: Bug


Attachments (Terms of Use)
A gzipped preprocessed source (130.96 KB, application/octet-stream)
2020-02-24 09:39 UTC, Petr Pisar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 93763 0 P1 RESOLVED [10 Regression] ice in propagate_vals_across_arith_jfunc, at ipa-cp.c:2039 2020-10-05 10:49:30 UTC

Description Petr Pisar 2020-02-24 09:39:50 UTC
Created attachment 1665351 [details]
A gzipped preprocessed source

After upgrading gcc from 10.0.1-0.7.fc32.x86_64 to 10.0.1-0.8.fc33.x86_64 I observe an internal compiler error when building perl-Devel-NYTProf-6.06-8.fc33 package <https://koschei.fedoraproject.org/build/7985159>:

gcc -c   -D_REENTRANT -D_GNU_SOURCE -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fwrapv -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection   -DVERSION=\"6.06\" -DXS_VERSION=\"6.06\" -fPIC "-I/usr/lib64/perl5/CORE"  -DHAS_CLOCK_GETTIME -DHAS_ZLIB -W -Wall -Wpointer-arith -Wbad-function-cast -Wno-comment -Wno-sign-compare -Wno-cast-qual NYTProf.c
In file included from NYTProf.xs:36:
ppport.h:4594: warning: "WIDEST_UTYPE" redefined
 4594 | #  define WIDEST_UTYPE U64TYPE
      | 
In file included from /usr/lib64/perl5/CORE/perl.h:2525,
                 from NYTProf.xs:20:
/usr/lib64/perl5/CORE/handy.h:1072: note: this is the location of the previous definition
 1072 | #   define WIDEST_UTYPE U64
      | 
NYTProf.xs:1220:1: warning: ‘get_str_id’ defined but not used [-Wunused-function]
 1220 | get_str_id(pTHX_ char* str, STRLEN len)
      | ^~~~~~~~~~
*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_UNIT               | annobin: Generate final annotations
PLUGIN_START_UNIT                | annobin: Generate global annotations
PLUGIN_ALL_PASSES_START          | annobin: Generate per-function annotations
PLUGIN_ALL_PASSES_END            | annobin: Register per-function end symbol
during IPA pass: cp
NYTProf.c:5851:1: internal compiler error: in propagate_vals_across_arith_jfunc, at ipa-cp.c:2039
 5851 | }
      | ^

I minimized the compiler options to:

$ gcc -c -DVERSION=\"6.06\" -DXS_VERSION=\"6.06\" -I/usr/lib64/perl5/CORE -O2 NYTProf.c

It happens since -O2 optimization level. A preprorocessed source with these options is attached.

Comment 1 Jakub Jelinek 2020-03-12 10:36:52 UTC
Should be fixed in gcc-10.0.1-0.9.fc{32,33}, the f32 version hasn't finished building yet.

Comment 2 Petr Pisar 2020-03-12 12:07:47 UTC
I confirm that the package builds fine again with gcc-10.0.1-0.9.fc33.x86_64.

Comment 3 Fedora Update System 2020-03-13 10:48:41 UTC
FEDORA-2020-d927e07eb1 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d927e07eb1

Comment 4 Fedora Update System 2020-03-13 18:33:40 UTC
annobin-9.06-4.fc32, gcc-10.0.1-0.9.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d927e07eb1

Comment 5 Fedora Update System 2020-03-16 20:39:08 UTC
annobin-9.06-4.fc32, gcc-10.0.1-0.9.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.