Bug 180654 - does not suspend on lid close when configured to do so; explicit suspend works
does not suspend on lid close when configured to do so; explicit suspend works
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 13:52 EST by Monty
Modified: 2013-10-20 18:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-18 16:27:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Monty 2006-02-09 13:52:24 EST
Description of problem:
When configured to suspend on lid close, the backlight and screen are turned off
via DPMS, but no suspend is attempted.  Selecting 'suspend' from the dropdown
does suspend the machine on lid close.

Debug output while running in gdb [included below] seems to indicate the applet
never attemps a suspend.

Hibernate is also broken in the same way.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.13.5.0.20060207-1

How reproducible:
Every time

Steps to Reproduce:
1. Under preferences, set lid close behavior to 'suspend'
2. Close preferences
3. close laptop lid
  
Actual results:
screen turned off; no suspend 

Expected results:
Laptop enters suspend

Additional info:
[root@dhcp83-27 xiphmont]# gdb --args gnome-power-manager --no-daemon --verbose
GNU gdb Red Hat Linux (6.3.0.0-1.98rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db li
rary "/lib/libthread_db.so.1".

(gdb) r
Starting program: /usr/bin/gnome-power-manager --no-daemon --verbose
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xf65000
[Thread debugging using libthread_db enabled]
[New Thread -1208367440 (LWP 9651)]

(gnome-power-manager:9651): GnomeUI-WARNING **: While connecting to session man
ger:
Authentication Rejected, reason : None of the authentication protocols specifie
 are supported and host-based authentication failed.
Detaching after fork from child process 9654.

** (gnome-power-manager:9651): WARNING **: Unable to load icon gnome-dev-memory
** (gnome-power-manager:9651): DEBUG: Power management type : acpi
** (gnome-power-manager:9651): DEBUG: Setting on-ac: 1
** (gnome-power-manager:9651): DEBUG: No devices of capability laptop_panel
** (gnome-power-manager:9651): DEBUG: setting DPMS enabled: 1
** (gnome-power-manager:9651): DEBUG: Syncing DPMS settings enabled=1 timeouts=
 0 0
** (gnome-power-manager:9651): DEBUG: Syncing DPMS settings enabled=1 timeouts=
 0 0
** (gnome-power-manager:9651): DEBUG: Getting stock icon for tray
** (gnome-power-manager:9651): DEBUG: Going to use stock id: gnome-dev-acadapte
** (gnome-power-manager:9651): DEBUG: creating new tray icon
** (gnome-power-manager:9651): DEBUG: done creating new tray icon 0x994f030
** (gnome-power-manager:9651): DEBUG: tooltip: Computer is running on AC power

** (gnome-power-manager:9651): WARNING **: gpm_hal_enable_power_save: No powers
ve method found
** (gnome-power-manager:9651): DEBUG: org.freedesktop.Hal.Device.SystemPowerMan
gement.SetPowerSave failed (HAL error)
** (gnome-power-manager:9651): DEBUG: gnome-screensaver setThrottleEnabled : 0

** (gnome-power-manager:9651): WARNING **: gpm_screensaver_enable_throttle: The
name org.gnome.ScreenSaver was not provided by any .service files
** (gnome-power-manager:9651): DEBUG: gnome-screensaver service is not running.
** (gnome-power-manager:9651): DEBUG: gnome-screensaver setThrottleEnabled fail
d
** (gnome-power-manager:9651): DEBUG: Setting system idle timeout: 0
** (gnome-power-manager:9651): DEBUG: Syncing DPMS settings enabled=1 timeouts=
 0 0
** (gnome-power-manager:9651): DEBUG: Adding new device to watch: /org/freedesk
op/Hal/devices/acpi_BAT0
** (gnome-power-manager:9651): DEBUG: Creating proxy for: /org/freedesktop/Hal/
evices/acpi_BAT0
** (gnome-power-manager:9651): DEBUG: Emitting battery-added signal for: /org/f
eedesktop/Hal/devices/acpi_BAT0
** (gnome-power-manager:9651): DEBUG: hal_battery_added_cb(...) Battery Added: 
org/freedesktop/Hal/devices/acpi_BAT0
** (gnome-power-manager:9651): DEBUG: adding /org/freedesktop/Hal/devices/acpi_
AT0
** (gnome-power-manager:9651): DEBUG: gpm_hal_device_get_int: No property batte
y.remaining_time on device with id /org/freedesktop/Hal/devices/acpi_BAT0
** (gnome-power-manager:9651): DEBUG: 1 devices of type Laptop battery
** (gnome-power-manager:9651): DEBUG: Getting stock icon for tray
** (gnome-power-manager:9651): DEBUG: Going to use stock id: gnome-power-ac-cha
ged
** (gnome-power-manager:9651): DEBUG: tooltip: Computer is running on AC power
Unknown time until charged (99%)
** (gnome-power-manager:9651): DEBUG: percentage = 99, remaining_time = 0, disc
arging = 0, charging = 0, battery_kind = 0
** (gnome-power-manager:9651): DEBUG: maybe_notify_battery_status_changed: Prim
ry battery is not discharging!
** (gnome-power-manager:9651): DEBUG: Primary battery capacity: 1.000000
** (gnome-power-manager:9651): DEBUG: Printing Laptop battery device parameters
** (gnome-power-manager:9651): DEBUG: number_devices    = 1
** (gnome-power-manager:9651): DEBUG: is_present        = 1
** (gnome-power-manager:9651): DEBUG: design_charge     = 71280
** (gnome-power-manager:9651): DEBUG: last_full_charge  = 62880
** (gnome-power-manager:9651): DEBUG: current_charge    = 62680
** (gnome-power-manager:9651): DEBUG: charge_rate       = 0
** (gnome-power-manager:9651): DEBUG: percentage_charge = 99
** (gnome-power-manager:9651): DEBUG: remaining_time    = 0
** (gnome-power-manager:9651): DEBUG: is_charging       = 0
** (gnome-power-manager:9651): DEBUG: is_discharging    = 0
** (gnome-power-manager:9651): DEBUG: Adding new device to watch: /org/freedesk
op/Hal/devices/acpi_AC
** (gnome-power-manager:9651): DEBUG: Creating proxy for: /org/freedesktop/Hal/
evices/acpi_AC
** (gnome-power-manager:9651): DEBUG: Adding new device to watch: /org/freedesk
op/Hal/devices/acpi_SLPB
** (gnome-power-manager:9651): DEBUG: Creating proxy for: /org/freedesktop/Hal/
evices/acpi_SLPB
** (gnome-power-manager:9651): DEBUG: Adding new device to watch: /org/freedesk
op/Hal/devices/acpi_PWRF
** (gnome-power-manager:9651): DEBUG: Creating proxy for: /org/freedesktop/Hal/
evices/acpi_PWRF
** (gnome-power-manager:9651): DEBUG: Adding new device to watch: /org/freedesk
op/Hal/devices/acpi_LID
** (gnome-power-manager:9651): DEBUG: Creating proxy for: /org/freedesktop/Hal/
evices/acpi_LID
** (gnome-power-manager:9651): DEBUG: watch_device_condition: udi=/org/freedesk
op/Hal/devices/acpi_LID, name=ButtonPressed, details=
** (gnome-power-manager:9651): DEBUG: ButtonPressed : lid
** (gnome-power-manager:9651): DEBUG: Received a button press event type=lid de
ails= state=1
** (gnome-power-manager:9651): DEBUG: lid_button_pressed: button changed: 1
** (gnome-power-manager:9651): DEBUG: lid_button_pressed: Ignoring policy as on
AC
** (gnome-power-manager:9651): DEBUG: DPMS mode changed: 3
** (gnome-power-manager:9651): DEBUG: gnome-screensaver setThrottleEnabled : 1

** (gnome-power-manager:9651): WARNING **: gpm_screensaver_enable_throttle: The
name org.gnome.ScreenSaver was not provided by any .service files
** (gnome-power-manager:9651): DEBUG: gnome-screensaver service is not running.
** (gnome-power-manager:9651): DEBUG: gnome-screensaver setThrottleEnabled fail
d
** (gnome-power-manager:9651): DEBUG: watch_device_condition: udi=/org/freedesk
op/Hal/devices/acpi_LID, name=ButtonPressed, details=
** (gnome-power-manager:9651): DEBUG: ButtonPressed : lid
** (gnome-power-manager:9651): DEBUG: Received a button press event type=lid de
ails= state=0
** (gnome-power-manager:9651): DEBUG: lid_button_pressed: button changed: 0
** (gnome-power-manager:9651): DEBUG: DPMS mode changed: 0
** (gnome-power-manager:9651): DEBUG: gnome-screensaver setThrottleEnabled : 0

** (gnome-power-manager:9651): WARNING **: gpm_screensaver_enable_throttle: The
name org.gnome.ScreenSaver was not provided by any .service files
** (gnome-power-manager:9651): DEBUG: gnome-screensaver service is not running.
** (gnome-power-manager:9651): DEBUG: gnome-screensaver setThrottleEnabled fail
d
Comment 1 Richard Hughes 2006-02-10 05:39:17 EST
>** (gnome-power-manager:9651): DEBUG: lid_button_pressed: button changed: 1
>** (gnome-power-manager:9651): DEBUG: lid_button_pressed: Ignoring policy as on AC

The issue is related to this:

http://bugzilla.gnome.org/show_bug.cgi?id=329512

Does the suspend work okay when on battery power? I bet it does. Can you re-open
the gnome.org bug please, if this is not as expected.

Thanks, Richard.
Comment 2 Monty 2006-02-10 12:20:50 EST
I will test this very shortly (as of a recent upgrade, I cannot successfully
come back from suspend, and I have state I don't want to drop yet), but yes I
had been testing while plugged in.

As for this being intentional behavior...  I will spare the logs the all-caps
profanities, but you're kidding right? (not you specifiaclly, of course.  This
is a nebulous unfocused collective 'you', much the same as the nefarious
'Them').  The dialog plainly says 'lid close: suspend', I close the lid, it
doesn't suspend.  There is no fine print anywhere that explains the option
really means 'suspend on odd tuesdays, but only if I feel like it this week.'

[on  a more literally flamey note, there are a number of laptops out there that
will bake themselves if fully powered on with the lid closed.]
Comment 3 Richard Hughes 2006-02-11 05:15:35 EST
Can you reopen, and add the last comment to
http://bugzilla.gnome.org/show_bug.cgi?id=329512 please, and we'll discuss it
upstream. Thanks, Richard.
Comment 4 Monty 2006-02-14 12:22:48 EST
I am unable to do; Buzilla is offering me no option for reopening the bug.
Comment 5 Richard Hughes 2006-02-15 19:22:25 EST
Ohh, no worries. Can you open a new bug and we'll discuss there with the other
developers. Thanks.
Comment 6 Richard Hughes 2006-02-18 16:27:50 EST
Fixed upstream. There's now lid policy for both power states.

Note You need to log in before you can comment on or make changes to this bug.