Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806727 - iwlwifi fails to load firmware
Summary: iwlwifi fails to load firmware
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 20:42 UTC by E. Staats
Modified: 2020-03-10 15:00 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 15:00:04 UTC
Type: Bug


Attachments (Terms of Use)
kernel logs (101.37 KB, text/plain)
2020-02-24 20:42 UTC, E. Staats
no flags Details

Description E. Staats 2020-02-24 20:42:29 UTC
Created attachment 1665498 [details]
kernel logs

1. Please describe the problem:

iwlwifi fails to load firmware for Intel Corporation Dual Band Wireless-AC 3168NGW [Stone Peak].

https://patchwork.kernel.org/patch/11353871/
https://lkml.org/lkml/2020/2/7/811
https://bugzilla.kernel.org/show_bug.cgi?id=206329
https://bugs.gentoo.org/706810
https://bbs.archlinux.org/viewtopic.php?id=252603

2. What is the Version-Release number of the kernel:

kernel-5.5.5-200.fc31

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

kernel-5.5.5-200.fc31. Older kernels run fine. 

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Boot into Fedora with kernel-5.5.5-200.fc31

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Got a GPG error when I tried to install latest kernel.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Justin M. Forbes 2020-03-03 16:22:21 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 31 kernel bugs.

Fedora 31 has now been rebased to 5.5.7-200.fc31.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

If you experience different issues, please open a new bug report for those.

Comment 2 E. Staats 2020-03-10 12:38:39 UTC
5.5.7-200.fc31 works perfectly. Thank you.

Comment 3 Hans de Goede 2020-03-10 15:00:04 UTC
(In reply to E. Staats from comment #2)
> 5.5.7-200.fc31 works perfectly. Thank you.

Ok, thank you for letting us know.


Note You need to log in before you can comment on or make changes to this bug.