Bug 1806769 - regression: history -S no longer merges command history as described.
Summary: regression: history -S no longer merges command history as described.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tcsh
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jan Macku
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 00:51 UTC by Eugene Kanter
Modified: 2020-11-28 02:03 UTC (History)
10 users (show)

Fixed In Version: tcsh-6.22.03-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-28 02:03:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Eugene Kanter 2020-02-25 00:51:12 UTC
Description of problem:

After recent changes in tcsh the command history -S ignores merge directive and simply writes out current shell history, overriding .history file.

Version-Release number of selected component (if applicable):

tcsh-6.22.02-1.fc31.x86_64

How reproducible:
always

Steps to Reproduce:
1. make sure there is a line as below or similar in .cshrc
set savehist = (1024 merge lock)
2. open two terminal windows for user which set to use csh or tcsh
3. open .history in gedit.
4. start from clean .history, preserve original if needed.
5. run several different commands in one shell, use history -S as last one.
6. observe command list written in .history
7. run history -S in second shell.

Actual results:
.history is completely erased except for last history -S.

Expected results:
both shells command list is merged into .history

Additional info:
tcsh-6.20.00 from RHEL v8 works correctly.

Comment 1 Eugene Kanter 2020-05-25 02:37:46 UTC
Just checking if anyone is looking at this and/or upstream bug needs to be filed to proceed.

Comment 2 Jan Macku 2020-05-26 11:05:52 UTC
Hello,
I'm sorry about delay, due to time reasons I wasn't able to have a look at this issue.

I'll contact upstream and let you know about any updates.

Jan

Comment 3 Eugene Kanter 2020-06-16 02:22:10 UTC
Any updates from upstream? Fedora 32 exhibits the same problem.

Comment 4 Jan Macku 2020-06-16 06:34:40 UTC
Hello,
no updates from upstream. I'm sure they'll get to it at some point.

I'll let you know.

Thank you for your patience
Jan

Comment 5 Eugene Kanter 2020-08-15 03:07:48 UTC
Was is the upstream bug number?

Comment 6 Eugene Kanter 2020-09-11 14:29:38 UTC
Almost three months later - any updates?

Comment 7 Jan Macku 2020-09-14 06:48:49 UTC
Hello,
still no updates from upstream.

May I ask you, are you using NFS for your home directory?
If not, I thing that removing 'lock' keyword from 'set savehist = (1024 merge lock)' might help.

Jan

Comment 8 Eugene Kanter 2020-09-14 19:33:40 UTC
What is relevant upstream bug?

Comment 9 Eugene Kanter 2020-09-14 19:34:56 UTC
(In reply to Jan Macku from comment #7)
> 
> May I ask you, are you using NFS for your home directory?
> If not, I thing that removing 'lock' keyword from 'set savehist = (1024
> merge lock)' might help.

I am not using NFS but lock keyword is for preventing multiple shells from stepping on each other while updating .history file as far as I can see.

Comment 10 Eugene Kanter 2020-11-18 19:40:20 UTC
6.22.03 supposedly resolved this regression.

Comment 11 Eugene Kanter 2020-11-18 23:32:18 UTC
It appears that one line fix has been available since February:

https://github.com/tcsh-org/tcsh/commit/6bc746caad28d0f1ffaf07a4ea1468e8efcc6d52

Comment 12 Jan Macku 2020-11-19 10:00:51 UTC
Hello,
thank you for your investigation.

Upstream released new version: https://github.com/tcsh-org/tcsh/releases/tag/TCSH6_22_03

I'll rebase tcsh version in rawhide, f34 and f33 to this version.

Comment 13 Fedora Update System 2020-11-19 11:28:28 UTC
FEDORA-2020-ef7b8e64d7 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ef7b8e64d7

Comment 14 Fedora Update System 2020-11-20 02:14:54 UTC
FEDORA-2020-ef7b8e64d7 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-ef7b8e64d7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-ef7b8e64d7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Eugene Kanter 2020-11-23 16:28:47 UTC
Where is the package?

$ sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-ef7b8e64d7
[sudo] password for : 
Last metadata expiration check: 0:22:14 ago on Mon 23 Nov 2020 11:01:38 AM EST.
No security updates needed, but 86 updates available
Dependencies resolved.
Nothing to do.
Complete!

Comment 16 Eugene Kanter 2020-11-23 16:49:27 UTC
Never mind, I had versionlock still on.

Comment 17 Fedora Update System 2020-11-28 02:03:08 UTC
FEDORA-2020-ef7b8e64d7 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.