Bug 180705 - USR997902 not recognized
USR997902 not recognized
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 15:26 EST by Daniele Gallina
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 21:19:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniele Gallina 2006-02-09 15:26:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
US Robotics 7902 (Gigabit Ethernet PCI Card) is not recognized by the kernel, but it has a r8169. How to fix the problem?
Other problem, if I try to compile US Robotics' kernel module for 7902 it say:

make -C src/ clean
make[1]: Entering directory `/root/r8169/src'
rm -f *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags
make[1]: Leaving directory `/root/r8169/src'
make -C src/ modules
make[1]: Entering directory `/root/r8169/src'
make -C /lib/modules/2.6.11-1.1369_FC4/build SUBDIRS=/root/r8169/src modules
make[2]: Entering directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'
  CC [M]  /root/r8169/src/r8169_n.o
make[2]: Leaving directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'
make[1]: Leaving directory `/root/r8169/src'
/root/r8169/src/r8169_n.c: In function ‘rtl8169_init_board’:
/root/r8169/src/r8169_n.c:717: error: ‘struct pci_dev’ has no member named ‘slot_name’
make[3]: *** [/root/r8169/src/r8169_n.o] Error 1
make[2]: *** [_module_/root/r8169/src] Error 2
make[1]: *** [modules] Error 2
make: *** [modules] Error 2

What is the problem???

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4
2. Try to make USR drivers
  

Additional info:

lspci -v

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
	Flags: bus master, medium devsel, latency 64
	Memory at e4000000 (32-bit, prefetchable) [size=32M]
	Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	I/O behind bridge: 0000d000-0000dfff
	Memory behind bridge: e0000000-e3ffffff

00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
	Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
	Flags: bus master, medium devsel, latency 64
	I/O ports at f000 [size=16]

00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
	Flags: bus master, medium devsel, latency 64, IRQ 10
	I/O ports at e000 [size=32]

00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
	Flags: medium devsel, IRQ 9

00:0e.0 Ethernet controller: U.S. Robotics USR997902 10/100/1000 Mbps PCI Network Card (rev 10)
	Subsystem: U.S. Robotics USR997902 10/100/1000 Mbps PCI Network Card
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
	I/O ports at e400 [size=256]
	Memory at e7000000 (32-bit, non-prefetchable) [size=256]
	Expansion ROM at e6000000 [disabled] [size=128K]
	Capabilities: [dc] Power Management version 2

01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c) (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc Rage Pro Turbo AGP 2X
	Flags: bus master, stepping, medium devsel, latency 64, IRQ 11
	Memory at e0000000 (32-bit, non-prefetchable) [size=16M]
	I/O ports at d000 [size=256]
	Memory at e2000000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [50] AGP version 1.0
Comment 1 Dave Jones 2006-02-09 21:19:38 EST
problems compiling out-of-tree drivers need to be reported to the vendors of the
drivers.  It's not uncommon that they'll only compile against certain versions
of the kernel.

There is an r8169 module already in the latest kernel though.
It looks like you're running the original kernel that came with FC4.

Just 'yum update', and this should work.

Note You need to log in before you can comment on or make changes to this bug.