Bug 1807289 - Failed task during the deployment does not render the 'more' link which reveals the task output
Summary: Failed task during the deployment does not render the 'more' link which revea...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 5.*
Assignee: Jeff Brown
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 01:51 UTC by Paul Cuzner
Modified: 2020-03-26 21:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-26 21:44:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Paul Cuzner 2020-02-26 01:51:33 UTC
Description of problem:
Every failed task should be displayed with a 'more' link which when clicked opens up a modal containing the ansible task output in json form. This link is missing at least in some scenarios

Reported by Shawn Houston


Version-Release number of selected component (if applicable):
1.0

How reproducible:
Unclear

Steps to Reproduce:
1. run a deployment, and kill one nodes sshd to block progress
2. the deploy should fail, and errors displayed
3. check the error summary for a more link

Actual results:
User reporting that the 'more' link is missing

Expected results:
Every error should have a 'more' link to enable the problem to be diagnosed.


Additional info:

Comment 2 Paul Cuzner 2020-03-26 21:44:11 UTC
Unable to reproduce the issue. In my tests, and deployments done by others in the field teams the 'more' link is present


Note You need to log in before you can comment on or make changes to this bug.