Bug 180760 - anaconda still needs vesamodes from rhpxl
anaconda still needs vesamodes from rhpxl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 23:19 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 11:13:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-09 23:19:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060207 Fedora/1.5.0.1-2.1 Firefox/1.5.0.1

Description of problem:
20050902's rawhide was uninstallable because vesamodes is gone, but something python module used by anaconda (haven't been able to figure out exactly what) still needs the file, and raises an exception when it can't find it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start the installer

Actual Results:  Exception about missing rhpxl (sorry, I didn't take note of the exact pathnames becuase they looked easy to memorize, but now I can't remember what they were ;-(

Expected Results:  No such exception

Additional info:
Comment 1 Benoit Welterlen 2006-02-10 04:35:42 EST
More informations :

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 732, in ?
    import xsetup
  File "/usr/lib/anaconda/xsetup.py", line 20, in ?
    import rhpxl.xserver as xserver
  File "/usr/lib/python2.4/site-packages/rhpxl/__init__.py", line 2, in ?
    import monitor
  File "/usr/lib/python2.4/site-packages/rhpxl/monitor.py", line 429, in ?
    read_modes("vesamodes")
  File "/usr/lib/python2.4/site-packages/rhpxl/monitor.py", line 406, in read_ms
    fd = open("/usr/share/rhpxl/" + filename, 'r')
IOError: [Errno 2] No such file or directory: '/usr/share/rhpxl/vesamodes'
install exited abnormally
Comment 2 Prarit Bhargava 2006-02-10 08:37:01 EST
Benoit, this appears to be a duplicate of 170576, which is a duplicate of  
160660. 
 
P. 

*** This bug has been marked as a duplicate of 160660 ***
Comment 3 Alexandre Oliva 2006-02-10 20:58:09 EST
Err, I'm 200% sure it is not the same problem.  It doens't even look the same.

Note You need to log in before you can comment on or make changes to this bug.