This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 180768 - rebuild-sdk-features doesn't work when upgrading from 3.1.1 to 3.1.2
rebuild-sdk-features doesn't work when upgrading from 3.1.1 to 3.1.2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 01:29 EST by Ben Konrath
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 10:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stack trace that shows the non-starting eclipse issue (27.74 KB, text/plain)
2006-02-10 01:29 EST, Ben Konrath
no flags Details

  None (edit)
Description Ben Konrath 2006-02-10 01:29:16 EST
Created attachment 124479 [details]
stack trace that shows the non-starting eclipse issue
Comment 1 Ben Konrath 2006-02-10 01:29:16 EST
The rebuild-sdk-features script does not work when updating from 3.1.1 to 3.1.2.
There are references to 3.1.1 features in org.eclipse.sdk/feature.xml that
shouldn't be there.

Also, there are references to the rcp feature and/or source feature in
org.eclipse.sdk/feature.xml but I think this should only be refernced in
org.eclipse.platform/feature.xml because the platform includes the rcp not the sdk.

These two issues cause Eclipse to not start the second time it is used (see
attached stack trace) unless the -clean option is added to the commandline. 

I manually edited the feature.xml files to remove the references to both the
3.1.1 features and the rcp feature and the problem went away.
Comment 2 Andrew Overholt 2006-02-13 10:59:46 EST
This is fixed in rawhide as of 2006-02-11.

Note You need to log in before you can comment on or make changes to this bug.