Bug 180775 - printconf-tui crashes on startup complains can't import pyexpat
printconf-tui crashes on startup complains can't import pyexpat
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 04:13 EST by Tony Scholes
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 16:16:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Scholes 2006-02-10 04:13:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050811 Fedora/1.7.10-1.1.1.legacy

Description of problem:
Attempting to start printconf logged in as root produces the following :-

# printconf
Traceback (most recent call last):
  File "/usr/sbin/printconf", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 33, in ?
    import printconf_conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
  File "/usr/src/build/219081-i386/install/usr/lib/python2.2/site-packages/_xmlplus/utils/qp_xml.py", line 23, in ?
ImportError: cannot import name pyexpat


System is fully up to date (RH EL 3 Update 6 with all subsequent patches)


Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.23-1

How reproducible:
Always

Steps to Reproduce:
1. Login as root

2. type 'printconf' or 'printconf-tui'
3.
  

Actual Results:  # printconf
Traceback (most recent call last):
  File "/usr/sbin/printconf", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 33, in ?
    import printconf_conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
  File "/usr/src/build/219081-i386/install/usr/lib/python2.2/site-packages/_xmlplus/utils/qp_xml.py", line 23, in ?
ImportError: cannot import name pyexpat


Expected Results:  printconf utility should run as expected and allow the print system to be configured.

Additional info:
Comment 1 Tim Waugh 2006-02-10 04:28:39 EST
What do these commands say?:

rpm -V python
rpm -q python
Comment 2 Tony Scholes 2006-02-10 04:48:54 EST
Tim

# rpm -V python
# rpm -q python
python-2.2.3-6.1

Comment 3 Tim Waugh 2006-02-10 05:28:13 EST
What about these?:

python -c 'import pyexpat'
rpm -V PyXML
rpm -q PyXML
Comment 4 Tony Scholes 2006-02-10 05:38:16 EST
Tim

# python -c 'import pyexpat'
Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: /usr/lib/python2.2/lib-dynload/pyexpat.so: undefined symbol:
XML_ExpatVersionInfo
# rpm -V PyXML
# rpm -q PyXML
PyXML-0.7.1-9



Comment 5 Tim Waugh 2006-02-10 05:51:45 EST
Seems like it might be a python problem.  Changing component and reassigning.
Comment 6 Mihai Ibanescu 2006-04-06 13:46:11 EDT
I cannot reproduce this on U7, even though python hasn't changed. Did you have
expat installed?
Comment 7 Tony Scholes 2006-04-14 09:39:13 EDT
Hi

Sorry for the delay in responding...

This worked fine (it's how I configure pritners on all our customers systems) 
then one day just didn't anymore...

How can I tell if I have xpat installed?

TIA

Note You need to log in before you can comment on or make changes to this bug.