Bug 1807916 - [upstream] Tracker BZ for updating the upstream container image for UCI due to error with migration on Openstack
Summary: [upstream] Tracker BZ for updating the upstream container image for UCI due t...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.11.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: GA
: 5.11.4
Assignee: Tomáš Golembiovský
QA Contact: Md Nadeem
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 13:14 UTC by Md Nadeem
Modified: 2020-04-27 09:51 UTC (History)
2 users (show)

Fixed In Version: 5.11.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-17 13:24:10 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
simaishi: cfme-5.11.z?


Attachments (Terms of Use)

Description Md Nadeem 2020-02-27 13:14:31 UTC
Description of problem:

he migration on OSP failed at the very last stage due to some strange error, the volumes gets created successfully at OSP side then its gets detached from UCI conversion instance, Then it keeps on checking the volume status and failed.

~~~~~~~~~~~
:INFO: Current volume state: b'available'. (hosts:329)
2020-02-24 13:38:09,913:INFO: Executing command: ['openstack', '--insecure', '--os-auth-url=https://10.8.XX.YY:13000/v3', '--os-identity-api-version=3', '--os-user-domain-name=Default', '--os-username=admin', '--os-password=*****', '--os-project-name=admin', 'volume', 'show', '-f', 'value', '-c', 'status', '23e4d5cf-b75d-4405-8578-5aad642567d2'], environment: {} (common:108)
2020-02-24 13:38:13,204:INFO: Current volume state: b'available'. (hosts:329)
2020-02-24 13:38:33,224:INFO: have error: (300,) {} (common:67)
2020-02-24 13:38:33,225:ERROR: 300 (common:68)
~~~~~~~~~~~~~~~~~~

IMPORTANT NOTE: The issue is already fixed in below PR, However the container image is yet not updated in upstream image. So this BZ is to track it unless this fix is available in default container image ship with the upstream UCI 
 qcow2 image.

>> https://github.com/ManageIQ/manageiq-v2v-conversion_host/commit/490227d54ffa38c7a1d4fabece3ba30ee2ce0579

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Satoe Imaishi 2020-02-27 18:12:03 UTC
The PR is included in newly released v2v-conversion-host RPM v2.1.0, and a new upstream container image was just built to include the new RPM. Feel free to pull the latest container image, or pick up tonight's appliance image build.

This is going to CFME 5.11.4, so changed target release.

Comment 4 Md Nadeem 2020-03-05 06:37:31 UTC
I have verified the issue in version 5.11.4.1 with Downstream UCI image: v2v-conversion-host-appliance-5.11.4.1-1_scratch.x86_64.qcow2 which have below container image:

registry.redhat.io/cloudforms50/v2v-conversion-host-rhel8   latest   ee05cba58702   2 days ago   1.96 GB


Note You need to log in before you can comment on or make changes to this bug.