Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1807966 - [abrt] python3-libs: dump(): __init__.py:180:dump:BrokenPipeError: [Errno 32] Broken pipe
Summary: [abrt] python3-libs: dump(): __init__.py:180:dump:BrokenPipeError: [Errno 32]...
Keywords:
Status: CLOSED DUPLICATE of bug 1803823
Alias: None
Product: Fedora
Classification: Fedora
Component: python3
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6c502ab2e5ae286936c13734579...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 15:03 UTC by Gabríel Arthúr Pétursson
Modified: 2020-03-02 15:35 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-02 15:35:11 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.01 KB, text/plain)
2020-02-27 15:03 UTC, Gabríel Arthúr Pétursson
no flags Details
File: cpuinfo (2.47 KB, text/plain)
2020-02-27 15:03 UTC, Gabríel Arthúr Pétursson
no flags Details
File: environ (5.57 KB, text/plain)
2020-02-27 15:04 UTC, Gabríel Arthúr Pétursson
no flags Details
File: mountinfo (2.72 KB, text/plain)
2020-02-27 15:04 UTC, Gabríel Arthúr Pétursson
no flags Details
File: namespaces (129 bytes, text/plain)
2020-02-27 15:04 UTC, Gabríel Arthúr Pétursson
no flags Details
File: open_fds (246 bytes, text/plain)
2020-02-27 15:04 UTC, Gabríel Arthúr Pétursson
no flags Details

Description Gabríel Arthúr Pétursson 2020-02-27 15:03:40 UTC
Version-Release number of selected component:
python3-libs-3.7.6-2.fc31

Additional info:
reporter:       libreport-2.12.0
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service
cmdline:        python -m json.tool
crash_function: dump
exception_type: BrokenPipeError
executable:     /usr/lib64/python3.7/json/tool.py
interpreter:    python-unversioned-command-3.7.6-2.fc31.noarch
kernel:         5.4.15-200.fc31.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:180:dump:BrokenPipeError: [Errno 32] Broken pipe

Traceback (most recent call last):
  File "/usr/lib64/python3.7/runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib64/python3.7/runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "/usr/lib64/python3.7/json/tool.py", line 45, in <module>
    main()
  File "/usr/lib64/python3.7/json/tool.py", line 40, in main
    json.dump(obj, outfile, sort_keys=sort_keys, indent=4)
  File "/usr/lib64/python3.7/json/__init__.py", line 180, in dump
    fp.write(chunk)
BrokenPipeError: [Errno 32] Broken pipe

Local variables in innermost frame:
obj: { ... stripped sensitive info ... }
fp: <_io.TextIOWrapper name='<stdout>' mode='w' encoding='UTF-8'>
skipkeys: False
ensure_ascii: True
check_circular: True
allow_nan: True
cls: <class 'json.encoder.JSONEncoder'>
indent: 4
separators: None
default: None
sort_keys: False
kw: {}
iterable: <generator object _make_iterencode.<locals>._iterencode at 0x7f954d253450>
chunk: '"CompanyID"'

Comment 1 Gabríel Arthúr Pétursson 2020-02-27 15:03:50 UTC
Created attachment 1666223 [details]
File: backtrace

Comment 2 Gabríel Arthúr Pétursson 2020-02-27 15:03:59 UTC
Created attachment 1666224 [details]
File: cpuinfo

Comment 3 Gabríel Arthúr Pétursson 2020-02-27 15:04:06 UTC
Created attachment 1666225 [details]
File: environ

Comment 4 Gabríel Arthúr Pétursson 2020-02-27 15:04:12 UTC
Created attachment 1666226 [details]
File: mountinfo

Comment 5 Gabríel Arthúr Pétursson 2020-02-27 15:04:19 UTC
Created attachment 1666227 [details]
File: namespaces

Comment 6 Gabríel Arthúr Pétursson 2020-02-27 15:04:21 UTC
Created attachment 1666228 [details]
File: open_fds

Comment 7 Victor Stinner 2020-03-02 15:35:11 UTC

*** This bug has been marked as a duplicate of bug 1803823 ***


Note You need to log in before you can comment on or make changes to this bug.