Bug 18087 - Installation RedHat 7.0 by NFS
Summary: Installation RedHat 7.0 by NFS
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 23727 23742 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 13:55 UTC by Derrien
Modified: 2005-10-31 22:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-17 19:28:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derrien 2000-10-02 13:55:34 UTC
It seems impossible to install RedHat 7.0 by NFS; every time I get the
message
"I could not mount that directory from the server"

NB: With a RedHat 6.2 install diskette the same directory is mounted
without
problem.

Comment 1 Michael Fulbright 2000-10-02 22:01:37 UTC
Did you happen to copy the contents of both CDs to the NFS directory you are
installing from - this has changed from the procedure for 6.2.

Comment 2 David Ross 2000-10-03 02:56:05 UTC
Sounds like my bug #15190

Comment 3 David Ross 2000-10-03 02:56:49 UTC
Sounds like my bug #15190.
Are you able to turn off NFS version 3 on your server?  That worked for me.

Comment 4 panu.matilainen 2000-10-03 09:45:49 UTC
Turning off NFSv3 is absolutely not an option here .. which pretty much means no
RH7 for us before
this is fixed. BTW this bug was in pinstripe too, see
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=17240

Comment 5 Derrien 2000-10-03 13:58:35 UTC
Thanks for your help David.

My tests :

NFS server Solaris : mount impossible
NFS server RedHat 6.x without  --no-nfs-version 3 : mount impossible
NFS server Redhat 6.x with --no-nfs-version 3 :  mount works

Unfortunately all our NFS servers are on Solaris....

NB: When the NFS mounted directory does not contain RedHat/instimage
the message isn't "I could not mount that directory from the server" but
"That directory does not seem to contain a RedHat installation tree"


Comment 6 Bob Bell 2000-10-04 16:09:29 UTC
I've experienced this problem, too.  Right now I'm installing from a Linux NFS
server.  However, I was unable to install from a Compaq Tru64 UNIX NFS server,
as it offers NFSv3 (and I wasn't able to find a way to turn it off).  I'd
considered this a high priority bug.

Comment 7 David Ross 2000-10-04 18:51:44 UTC
This is also the same bug as 17609.

Comment 8 Mark Hankins 2000-10-05 06:55:38 UTC
NFS mounts fail on Network Appliance's NetApps as well.

Comment 9 Andrea Rivetti 2000-10-05 08:33:33 UTC
NFS installation fails from my SparcStation running OpenBSD. Any workaround?!




Comment 10 David Ross 2000-10-05 16:56:58 UTC
See bug# 17609

Comment 11 Marc Schmitt 2000-10-13 10:44:23 UTC
Our image server is an Sun Ultra-4. KS install over NFS with RH 6.0 and 6.2
worked great. No chance to get it running with 7.0, I simply can`t mount the
image directory.

Turning off NFSv3 on the server is not an option at all.

Comment 12 panu.matilainen 2000-10-13 10:49:59 UTC
There's an unofficial fix for this by tek@CS.Princeton.EDU at
http://www.cs.princeton.edu/redhat7-fix/ (see bug 17609) - worked for me at
least.

Comment 13 Michael Fulbright 2000-10-27 20:23:25 UTC
Thanks for the help everyone.

Could everyone trying the images

ftp://people.redhat.com/msf/bootnet-nfsv2.img

and/or

ftp://people.redhat.com/msf/pcmcia-nfsv2.img

(as appropriate) and let me know if these work?

I will make an errata release if these work.

Comment 14 Derrien 2000-10-30 08:20:14 UTC
ftp://people.redhat.com/msf/70nfs2/bootnet-nfsv2.img works for me

Comment 15 Marc Schmitt 2000-10-30 08:49:11 UTC
ftp://people.redhat.com/msf/bootnet-nfsv2.img works for me.

Comment 16 panu.matilainen 2000-10-30 08:58:20 UTC
Works for me too...

Comment 17 Michael Fulbright 2000-11-03 21:20:25 UTC
Thanks I will make an errata release of this new image since it seems to fix the
problem.

I appreciate the link to the unofficial fix!


Comment 18 David Ross 2000-11-06 22:24:52 UTC
Hmm.  I can't get this to work for me against a Network Appliance Filer.  Still
get "failed to mount 10.172.8.13:/vol/vol0/linux".  I've used the images from
msf.  Did you guys change anything besides the boot disk?

Comment 19 panu.matilainen 2000-11-07 09:24:51 UTC
Hmm.. worked for me on a NetApp with msf's bootdisk (nothing additional) just
fine.

Comment 20 Michael Fulbright 2000-11-17 19:28:54 UTC
Ok we've fixed this in our internal development tree.

Comment 21 Michael Fulbright 2001-01-10 21:27:49 UTC
*** Bug 23727 has been marked as a duplicate of this bug. ***

Comment 22 Matt Wilson 2001-01-11 19:20:39 UTC
*** Bug 23742 has been marked as a duplicate of this bug. ***

Comment 23 Need Real Name 2001-09-13 03:27:31 UTC
I don't know what was fixed but
ftp://people.redhat.com/msf/70nfs2/bootnet-nfsv2.img does not work for me.
I can access the same NFS directory if I use bootnet.img from 7.1 CD.
Unfortunately, aic7xxx in 7.1 does not work on VALinux 2240 and I cannot install
7.1 on that box.


Note You need to log in before you can comment on or make changes to this bug.