Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1808857 - "*** stack smashing detected ***: <unknown> terminated" error when installing the Nix package manager
Summary: "*** stack smashing detected ***: <unknown> terminated" error when installing...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-01 16:37 UTC by Hécate
Modified: 2020-10-05 08:29 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-03 16:31:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Hécate 2020-03-01 16:37:57 UTC
Installation log:

```
❯ curl https://nixos.org/nix/install | sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2399  100  2399    0     0   9872      0 --:--:-- --:--:-- --:--:--  9872
downloading Nix 2.3.3 binary tarball for x86_64-linux from 'https://nixos.org/releases/nix/nix-2.3.3/nix-2.3.3-x86_64-linux.tar.xz' to '/tmp/nix-binary-tarball-unpack.HeomkFIylv'...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 16.4M  100 16.4M    0     0  3109k      0  0:00:05  0:00:05 --:--:-- 3395k
Note: a multi-user installation is possible. See https://nixos.org/nix/manual/#sect-multi-user-installation
performing a single-user installation of Nix...
copying Nix to /nix/store......................................
*** stack smashing detected ***: <unknown> terminated
/tmp/nix-binary-tarball-unpack.HeomkFIylv/unpack/nix-2.3.3-x86_64-linux/install: line 117: 18073 Aborted                 (core dumped) "/bin/nix-store" --load-db < "/.reginfo"
/tmp/nix-binary-tarball-unpack.HeomkFIylv/unpack/nix-2.3.3-x86_64-linux/install: unable to register valid paths
```


Version-Release number of selected component (if applicable):

2.30


How reproducible:

Very reproducible

Steps to Reproduce:
1. $ curl https://nixos.org/nix/install | sh
2. Weep

Actual results:

"*** stack smashing detected ***: <unknown> terminated" error message

Expected results:

Having Nix installed on my machine

Additional info:

  Coredump:

```
mars 01 17:04:06 moira systemd-coredump[23219]: Process 23217 (nix-store) of user 1000 dumped core.
                                                
                                                Stack trace of thread 23217:
                                                #0  0x00007f2df70d9625 raise (libc.so.6)
                                                #1  0x00007f2df70c28d9 abort (libc.so.6)
                                                #2  0x00007f2df711d4af __libc_message (libc.so.6)
                                                #3  0x00007f2df71ae5d5 __GI___fortify_fail_abort (libc.so.6)
                                                #4  0x00007f2df71ae588 __stack_chk_fail (libc.so.6)
                                                #5  0x00007f2df727c838 __pthread_tunables_init (libpthread.so.0)
                                                #6  0x00007f2df726e13d __pthread_initialize_minimal (libpthread.so.0)
                                                #7  0x00007f2df726d00d _init (libpthread.so.0)
mars 01 17:04:06 moira systemd[1]: systemd-coredump@4-23218-0.service: Succeeded.
```

  Sysinfo: https://paste.centos.org/view/093f83bd

Comment 1 Hécate 2020-03-01 16:41:22 UTC
Moreover, I am quite certain that this bug report on Debian's side is related: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=948287

Comment 2 Florian Weimer 2020-03-03 15:15:11 UTC
Sorry, I can't reproduce this. Did you have LD_LIBRARY_PATH set by chance?

Comment 3 Hécate 2020-03-03 16:28:40 UTC
Hello Florian,

yes you are right, I did have LD_LIBRARY_PATH set to `/lib64`. 

Unsetting it made the installation work.

Thank you very much!


Note You need to log in before you can comment on or make changes to this bug.