Bug 180895 - BCM5780 device name problem
BCM5780 device name problem
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 06:58 EST by Lauri Jesmin
Modified: 2014-03-16 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 16:10:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sysreport (275.55 KB, application/bzip2)
2006-02-10 10:37 EST, Lauri Jesmin
no flags Details

  None (edit)
Description Lauri Jesmin 2006-02-10 06:58:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 CentOS/1.0.7-1.4.3.centos4 Firefox/1.0.7

Description of problem:
I have a IBM e326m server, witch internal ethernet controllers are BCM5780 and one extra controller BCM5721. RHEL 4U2 kernel does not seem to support BCM5780, but 4U3beta kernel does support.
However, one ethernet device is assigned different name, as one is devNUMBER, others are eth0 eth1. Number in name varies.

Version-Release number of selected component (if applicable):
kernel-2.6.9-27.EL

How reproducible:
Always

Steps to Reproduce:
1.Install kernel
2.Reboot
3.
  

Additional info:

I use i686 kernel on AMD64 server because of software requirements.

Lspci:
00:01.0 PCI bridge: Broadcom HT1000 PCI/PCI-X bridge
00:02.0 Host bridge: Broadcom HT1000 Legacy South Bridge
00:02.1 IDE interface: Broadcom HT1000 Legacy IDE controller
00:02.2 ISA bridge: Broadcom HT1000 LPC Bridge
00:03.0 USB Controller: Broadcom HT1000 USB Controller (rev 01)
00:03.1 USB Controller: Broadcom HT1000 USB Controller (rev 01)
00:03.2 USB Controller: Broadcom HT1000 USB Controller (rev 01)
00:04.0 VGA compatible controller: ATI Technologies Inc: Unknown device 515e (rev 01)
00:06.0 PCI bridge: Broadcom HT1000 PCI-X bridge (rev a3)
00:07.0 PCI bridge: Broadcom HT1000 PCI-X bridge (rev a3)
00:08.0 PCI bridge: Broadcom HT1000 PCI-Express bridge (rev a3)
00:09.0 PCI bridge: Broadcom HT1000 PCI-Express bridge (rev a3)
00:0a.0 PCI bridge: Broadcom HT1000 PCI-Express bridge (rev a3)
00:0b.0 PCI bridge: Broadcom HT1000 PCI-Express bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0d.0 PCI bridge: Broadcom HT1000 PCI/PCI-X bridge (rev b2)
01:0e.0 IDE interface: Broadcom BCM5785 (HT1000) SATA Native SATA Mode
01:0e.1 IDE interface: Broadcom BCM5785 (HT1000) SATA Native SATA Mode
02:03.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 08)
03:02.0 Fibre Channel: Emulex Corporation: Unknown device fc00 (rev 01)
04:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5780 Gigabit Ethernet (rev 03)
04:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5780 Gigabit Ethernet (rev 03)
07:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express (rev 11)

ifconfig -a:
dev32204  Link encap:Ethernet  HWaddr 00:11:25:C4:16:E8
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11

eth0      Link encap:Ethernet  HWaddr 00:10:18:01:74:72
          inet addr:193.40.5.228  Bcast:193.40.5.255  Mask:255.255.255.0
          inet6 addr: 2001:bb8:2002:500:210:18ff:fe01:7472/64 Scope:Global
          inet6 addr: fe80::210:18ff:fe01:7472/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:77 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9867 (9.6 KiB)  TX bytes:6191 (6.0 KiB)
          Interrupt:11

eth1      Link encap:Ethernet  HWaddr 00:11:25:C4:16:E9
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:560 (560.0 b)  TX bytes:560 (560.0 b)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Comment 1 John W. Linville 2006-02-10 10:23:16 EST
This is usually the result of a problem in the ifcfg-ethX scripts.  Can you 
please attach your /etc/sysconfig/network-scripts/ifcfg-eth* files? 
 
Alternatively, attach the output of running "sysreport"... 
Comment 2 Lauri Jesmin 2006-02-10 10:37:50 EST
Created attachment 124502 [details]
Sysreport
Comment 3 John W. Linville 2006-02-10 16:05:34 EST
I think this is an artifact caused by the bcm5780 ports getting detected as  
eth0 and eth1, but ifcfg-eth0 is referencing the bcm5721 port (which used to  
be eth0 but now should be eth2 by default).  
  
Did you configured the bcm5780 ports through kudzu?  
  
I would recommend removing the "HWADDR=" line  
from /etc/sysconfig/network-scripts/ifcfg-eth0, or (even better) rename it to  
ifcfg-eth2.  
  
I'm assigning this bug to someone much more knowledgeable about the kudzu and 
initscripts packages in case you experience further problems.  
Comment 4 Bill Nottingham 2006-02-10 16:10:26 EST
You only have one device->hardware address mapping defined in your ifcfg files
(00:10:18:01:74:72 -> eth0).

When that happens, the init scripts make sure that that hwaddr gets that device;
it does this by moving other devices out of the way to a temporary name
(devXXXXX).  Since there's no other configs referencing that hardware address,
it doesn't get renamed to anything else.

You can fix this by adding ifcfg-ethX (or whatever names) files that reference
the other hardware addresses present on the system.

Note You need to log in before you can comment on or make changes to this bug.