Bug 180922 - Clean up BugzillaQueryOptions
Clean up BugzillaQueryOptions
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Igor Foox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 10:48 EST by Igor Foox
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 16:52:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Foox 2006-02-10 10:48:21 EST
The terminology used in org.eclipse.team.bugzilla.model.BugzillaQueryOptions is
sort of messed up. There is productComponentOptions, getProductOptions(),
there's alternativeOptions which are really confusing because the key is called
the value and the value (which is a list of options) is called
I-don't-know-what. This terminology needs a cleanup and a refactoring.
Comment 1 Igor Foox 2006-02-15 16:51:33 EST
This was fixed and commited to CVS.
Comment 2 Igor Foox 2006-02-15 16:52:19 EST
Closing.

Note You need to log in before you can comment on or make changes to this bug.