Bug 180941 - distribution of binary jar files with no source
distribution of binary jar files with no source
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xemacs-sumo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-10 12:17 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 20051208-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 15:56:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-02-10 12:17:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The jdt component of xemacs-sumo contains at least two binary jar files with no source.

./xemacs-packages/etc/jde/java/lib/bsh.jar
./xemacs-packages/etc/jde/java/lib/checkstyle-all.jar

At least one of these is supposed to be LGPL, but I didn't check if we promise to deliver source anywhere (as per the license).

These jar files should really be Required from other packages.  bsh and checkstyle are both packaged by the JPackage Project.  These packages should be imported into FE and dependencies established.  This is how we handle jar file dependencies in other packages.

There's also ./xemacs-packages/etc/jde/doc/tli_rbl/tli_rbl.jar.  Is that built from sources included in this package?  I didn't look.


Version-Release number of selected component (if applicable):
xemacs-sumo-20051208-1

How reproducible:
Always

Steps to Reproduce:
1.See if the xemacs-sumo package contains unbuildable jar files.
2.
3.
  

Additional info:
Comment 1 Ville Skyttä 2006-02-12 05:49:42 EST
You're quite right.  Here's some status:

- tli_rbl, treeview applet used in jde and jdebug user guies, 
http://www.javaside.com/u_tliste.html , not free software.  I have a local patch
that gets rid of it without losing any functionality (generating plain HTML
table of contents in the specfile).  Will commit that to CVS today.

- bsh, LGPL.  Looks like the version from JPackage could be used as a drop-in
replacement.

- checkstyle, LGPL.  jde included in xemacs-sumo requires an earlier version of
checkstyle than what's available in JPackage.

- jde.jar: apparently not all sources in order to build it are included in
xemacs-sumo.  Will investigate.

- xslt.jar (in the xslt-process package inside the sumo): sources included, the
TrAX transformer (which I think would be enough) could be built with the deps
included in FC, but javac in Rawhide is currently so broken for me (javac
anything.java just hangs) that I cannot test.

So, maybe the only really problematic one is checkstyle, others can probably be
taken care of pretty easily (just by pointing at expected install locations of
the JPackage jars, without adding any rpm dependencies due to the nature of
xemacs-sumo), and jde.jar's sources need to be found and it built from them. 
Your thoughts?
Comment 2 Anthony Green 2006-02-12 08:47:30 EST
(In reply to comment #1)
> - xslt.jar (in the xslt-process package inside the sumo): sources included, the
> TrAX transformer (which I think would be enough) could be built with the deps
> included in FC, but javac in Rawhide is currently so broken for me (javac
> anything.java just hangs) that I cannot test.

That's kernel bug 179228.  Just boot on an earlier kernel to work-around.
I was able to rebuild this code, except for the Cocoon class.  We don't
currently ship Cocoon in Fedora.

> So, maybe the only really problematic one is checkstyle, others can probably be
> taken care of pretty easily (just by pointing at expected install locations of
> the JPackage jars, without adding any rpm dependencies due to the nature of
> xemacs-sumo), and jde.jar's sources need to be found and it built from them. 
> Your thoughts?

I'm not quite sure I follow.  What do you mean by not adding any rpm
dependencies?  Don't you think the right solution is to import bsh and
checkstyle into FE?


Comment 3 Ville Skyttä 2006-02-12 10:01:15 EST
(In reply to comment #2)

> That's kernel bug 179228.  Just boot on an earlier kernel to work-around.

Do you know of a repository that still holds an old enough Rawhide kernel?

> I was able to rebuild this code, except for the Cocoon class.  We don't
> currently ship Cocoon in Fedora.

Neither is Saxon there AFAICT, and Xalan 1.x is long gone, nobody should be
using it in the first place any more even if Xalan1.java would compile with Xalan 2.

> I'm not quite sure I follow.  What do you mean by not adding any rpm
> dependencies?  Don't you think the right solution is to import bsh and
> checkstyle into FE?

Sure, that would be nice and if they're in Extras, I'll adjust the xemacs-sumo
packages so that they're used if installed.  Well, apart from that IMO it makes
no sense to import an old checkstyle to FE, see comment 1.  I'm not sure what to
do about that.

I'm just saying that IMO it does not make sense to add all rpm dependencies that
the xemacs-sumo package can use to be fully functional, but rather just leave it
for people to install the additional packages for the functionality they use. 
All existing dependencies would be a _lot_ of things and even more dependencies
are missing from FC/FE for things that xemacs-sumo includes support for; for
example the prog-modes package inside the sumo alone contains some 30 or so
modes for different programming languages, many of which I think are fully
functional regarding non-essential bonus features only if the particular
interpreter or compiler or the like for the language is installed.
Comment 4 Anthony Green 2006-02-12 10:33:10 EST
(In reply to comment #3)
> (In reply to comment #2)
> 
> > That's kernel bug 179228.  Just boot on an earlier kernel to work-around.
> 
> Do you know of a repository that still holds an old enough Rawhide kernel?

No, I'm afraid not.  I just use the kernel that shipped with FC5t2, since yum
doesn't ever remove that one.
Comment 5 Ville Skyttä 2006-02-14 16:49:46 EST
Ok, the WIP version in CVS now builds xslt.jar (TrAX only).

Regarding the rest of the jars in jde, I'm in the progress of updating the
xemacs-upstream jde to a version that works with the new checkstyle.  Regarding
source code for jde.jar, I have not found any upstream (jde upstream, not
xemacs) version that would ship with the full source code in order to reproduce
jde.jar.  Will contact the authors.
Comment 6 Ville Skyttä 2006-02-28 17:49:57 EST
Status update: still no info from upstream about complete jde.jar source
availability.  I'll wait until the end of this week, and will drop the whole jde
package from xemacs-sumo early next week unless I hear some good news.
Comment 7 Ville Skyttä 2006-03-06 15:56:01 EST
I've dropped JDE from 20051208-2, now in devel and soon in FC-4.

Note You need to log in before you can comment on or make changes to this bug.