Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1809501 - gambas3-ide has broken "Save As"
Summary: gambas3-ide has broken "Save As"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gambas3
Version: 31
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 09:27 UTC by Ian Laurie
Modified: 2020-09-15 17:27 UTC (History)
0 users

Fixed In Version: gambas3-3.14.3-2.fc31 gambas3-3.15.1-1.fc32 gambas3-3.15.1-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-15 16:16:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian Laurie 2020-03-03 09:27:00 UTC
Description of problem:
gambas3-ide has broken "Save As" functionality in the basic editor.

Version-Release number of selected component (if applicable):
gambas3-ide-3.14.2-1.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run the Gambas3 IDE.
2. Select "Open File" to get to the basic editor.
3. Try to "File->Save As" and nothing happens.

Actual results:
The "File->Save As" function does nothing ("File->Save" still works).

Additional info:
If you use Gambas3 as a scripting engine, and the scripts have a ".gbs" suffix, you can use the basic editor and it gives you color syntax highlighting for the Gambas language, so it is useful as no other editor I know can do that.  Having the "Save As" function broken is a pain.

Comment 1 Tom "spot" Callaway 2020-03-03 20:01:24 UTC
I can't reproduce this on 3.14.3, so I'm going to push that as an update. Please test it and let me know.

Comment 2 Fedora Update System 2020-03-03 20:02:52 UTC
FEDORA-2020-81871ab406 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-81871ab406

Comment 3 Ian Laurie 2020-03-03 21:12:26 UTC
Thanks for the ultra-fast response.

I am still seeing it on 3.14.3 in both Xfce and MATE (tested on the same virtual machine).

I installed gambas3 from the normal repo on another virtual machine running GNOME (tested under Xorg) and confirmed the issue in 3.14.2.  I then upgraded from the same set of rpms downloaded previously (3.14.3) and the problem remains.

Just to confirm, my reported issue is from the editor you get to from the intro screen, not after creating or opening a project.

My way of installing is as follows:

(1) sudo dnf -y install gambas3-scripter gambas3-devel gambas3-runtime

then optionally:

(2) sudo dnf -y install gambas3-ide

By the way as an unrelated issue.... (1) above installs the gambas3.desktop file even though there is no IDE to launch while (2) does not install the gambas3.desktop file.  So if all you do is (1) to get scripting you really need to delete the desktop file.  

I don't really use the project facilities in the IDE, I install it to get the editor because nothing else [that I know of] can color syntax highlight Gambas3 source scripts/files.

Comment 4 Ian Laurie 2020-03-03 23:08:27 UTC
Appologies, it looks like (2) in comment #3 also installs the desktop file (but you have to log out and back in again to see it).  So probably installing the desktop file should be removed from (1).

Comment 5 Fedora Update System 2020-03-04 21:48:51 UTC
gambas3-3.14.3-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-81871ab406

Comment 6 Ian Laurie 2020-03-05 00:17:32 UTC
I'm still seeing this issue with gambas3-ide-3.14.3-2.fc31 (and gambas3-ide-3.14.3-2.fc32) across a multitude of virtual machines under Xfce, MATE and GNOME (with Xorg) on both Fedora 31 and the Fedora 32 beta branch, not sure why you cannot reproduce the  problem.  

It is minor issue however.

Comment 7 Tom "spot" Callaway 2020-03-10 17:05:26 UTC
I was able to reproduce this. Opened a bug upstream:
http://gambaswiki.org/bugtracker/edit?object=BUG.1751

Comment 8 Fedora Update System 2020-03-12 21:56:06 UTC
gambas3-3.14.3-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Ian Laurie 2020-03-16 05:35:32 UTC
This issue is pending an upstream fix, bug should still be open.

Comment 10 Fedora Admin user for bugzilla script actions 2020-06-03 02:48:47 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 11 Ian Laurie 2020-09-05 01:02:26 UTC
This is still an issue in gambas3-ide-3.14.3-2.fc32.x86_64 in Fedora 32 (and presumably Fedora 31 as well).

However the problem is fixed in gambas3-ide-3.15.1-1.fc34.x86_64 in Rawhide, and also in gambas3-ide-3.15.1-1.fc33.x86_64 in the Fedora 33 beta branch.

Comment 12 Fedora Update System 2020-09-06 21:20:07 UTC
FEDORA-2020-28765f4349 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-28765f4349

Comment 13 Fedora Update System 2020-09-06 21:20:08 UTC
FEDORA-2020-75365347fb has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-75365347fb

Comment 14 Fedora Update System 2020-09-07 17:20:59 UTC
FEDORA-2020-75365347fb has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-75365347fb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-75365347fb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-09-07 17:56:59 UTC
FEDORA-2020-28765f4349 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-28765f4349`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-28765f4349

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Ian Laurie 2020-09-07 21:58:24 UTC
Fixed in Fedora 32.

Comment 17 Fedora Update System 2020-09-15 16:16:15 UTC
FEDORA-2020-75365347fb has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-09-15 17:27:04 UTC
FEDORA-2020-28765f4349 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.