Bug 1809959 - `oc version -o yaml` show major and minor with empty string
Summary: `oc version -o yaml` show major and minor with empty string
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1809961
TreeView+ depends on / blocked
 
Reported: 2020-03-04 10:06 UTC by zhou ying
Modified: 2020-03-04 14:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1809961 (view as bug list)
Environment:
Last Closed: 2020-03-04 14:46:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description zhou ying 2020-03-04 10:06:51 UTC
Description of problem:
`oc version -o yaml` show major and minor with empty string 

Version-Release number of selected component (if applicable):
[root@dhcp-140-138 cucushift]#  oc version -o yaml 
clientVersion:
  buildDate: "2020-02-28T23:32:38Z"
  compiler: gc
  gitCommit: bc08a48555986f64165555efd2705eff7ef2de81
  gitTreeState: clean
  gitVersion: 4.4.0-202002282323-bc08a48
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64


How reproducible:
always

Steps to Reproduce:
1.`oc version -o yaml`
2.
3.

Actual results:
Show major and minor with empty string :
[root@dhcp-140-138 cucushift]#  oc version -o yaml 
clientVersion:
  buildDate: "2020-02-28T23:32:38Z"
  compiler: gc
  gitCommit: bc08a48555986f64165555efd2705eff7ef2de81
  gitTreeState: clean
  gitVersion: 4.4.0-202002282323-bc08a48
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

Expected results:
Show valid value.

Additional info:

Comment 1 Maciej Szulik 2020-03-04 14:46:34 UTC
This is working as intended, they won't be filled.


Note You need to log in before you can comment on or make changes to this bug.