Bug 181012 - keyboard does not function at all during install
keyboard does not function at all during install
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-11 12:57 EST by Patrick Mansfield
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 14:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Mansfield 2006-02-11 12:57:42 EST
Description of problem:

While trying a network boot and install on a JS20 (ppc64) system via the serial
over lan, the keyboard does not work at all.

Version-Release number of selected component (if applicable):

Using fc devel ppc snapshot with timestamps feb 9 2006, it has:

anaconda-10.91.19-1.ppc.rpm
kernel-2.6.15-1.1928_FC5.ppc64.rpm

How reproducible:

I'm hitting this everytime (3 out of 3 tries). Previous installs worked fine
(snapshot of about 3 weeks ago).

Steps to Reproduce:
1. Network boot using ppc/images/netboot/ppc64.img
2. Try to select language or network
  
Actual results:

Keyboard input is ignored, I can't select the language or network for the
installation (there are two eth's on the system).

There is text output, so the serial line is functioning.
Comment 1 Paul Nasrat 2006-02-11 17:34:04 EST
Manoj can you reproduce this.
Comment 2 Patrick Mansfield 2006-02-13 13:14:56 EST
I just tried with ppc/image/netboot/ppc64.img dated today (feb 13 2006), and the
keyboard is working again.

I am rsyncing my fc devel ppc directory (takes about an hour ...), I'll try an
install later today, and close this if it works OK.

But it would be nice to know if something was fixed.
Comment 3 Jeremy Katz 2006-02-13 13:22:22 EST
Sounds to me like there was a kernel broken.  Considering the kernel is getting
rebased once or twice a day, the chances of that being related are high
Comment 4 Patrick Mansfield 2006-02-13 14:47:38 EST
I was able to netboot and start a full install.

Note You need to log in before you can comment on or make changes to this bug.