Bug 181043 - kernel-xen-guest added in grub boot menu
kernel-xen-guest added in grub boot menu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 00:50 EST by Kiyo Sekimoto
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-12 12:30:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kiyo Sekimoto 2006-02-12 00:50:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.8.0.1) Gecko/20060208 Fedora/1.5.0.1-2.1 Firefox/1.5.0.1

Description of problem:
I have installed xen, kernel-xen-hypervisor and kernel-xen-guest on FC5-test2 using  yum then kernel-xen-guest has been added in the grub boot menu. Because this kernel is not bootable on the native machine, it should not be added in the boot menu.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.51_FC5

How reproducible:
Always

Steps to Reproduce:
1.Install xen,kernel-xen-hypervisor and kernel-xen-guest on FC5-test2.
2.
3.
  

Actual Results:  kernel-xen-guest has been added in the boot menu.

Expected Results:  kernel-xen-guest should not be added in the boot menu.

Additional info:

/boot/grub/grub.conf after installing xen kernels.

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hda
default=2
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.15-1.51_FC5guest)
        root (hd0,0)
        kernel /vmlinuz-2.6.15-1.51_FC5guest ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.15-1.51_FC5guest.img
title Fedora Core (2.6.15-1.51_FC5hypervisor)
        root (hd0,0)
        kernel /xen.gz-2.6.15-1.51_FC5
        module /vmlinuz-2.6.15-1.51_FC5hypervisor ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        module /initrd-2.6.15-1.51_FC5hypervisor.img
title Fedora Core (2.6.15-1.1928_FC5)
        root (hd0,0)
        kernel /vmlinuz-2.6.15-1.1928_FC5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.15-1.1928_FC5.img
title Fedora Core (2.6.15-1.1826.2.10_FC5)
        root (hd0,0)
        kernel /vmlinuz-2.6.15-1.1826.2.10_FC5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.15-1.1826.2.10_FC5.img
Comment 1 Rik van Riel 2006-02-12 12:30:44 EST
Since we use grub inside guest virtual machines too, it is necessary that the
guest kernel is added to the grub menu.

While it is true that installing kernel-xen-guest on the host system does result
in a non-bootable entry in the grub menu, this is not a big problem since:
1) the Xen entries are not booted by default
2) kernel-xen-guest should not be installed in the host anyway

Note You need to log in before you can comment on or make changes to this bug.