Bug 181046 - upgrade hangs mmapping huge lastlog
upgrade hangs mmapping huge lastlog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 03:58 EST by Mark Montague
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 08:42:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Montague 2006-02-12 03:58:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060208 Debian/1.5.dfsg+1.5.0.1-1 Firefox/1.5.0.1

Description of problem:
I installed fc3 minimal, then tried to do up2date -u -- I tracked it down to upgrading shadow-utils. I downloaded shadow-utils-4.0.3-56.x86_64.rpm and tried to install by hand, and it hung, and top showed that it is using over a terabyte of virtual memory. I straced it, and found it was mmapping /var/log/lastlog, which, possibly because something "logged in" as nfsnobody, was (sort of) a >1 terabyte file (yeah, I know it's really a sparse file, as described in https://www.redhat.com/archives/fedora-list/2005-March/msg00076.html but apparently mmap doesn't fully understand that, or at least does something stupid. As a workaround, I rm -f'ed /var/log/lastlog and installed the rpm, but it's clearly broken, and took me many hours to figure out. 

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-56

How reproducible:
Didn't try

Steps to Reproduce:
1.
2.
3.
  

Additional info:

I don't see an easy way of getting the /var/log/lastlog file to go into "huge" mode again without scratch installing the whole system, which I really don't have time to do right now-- sorry.
Comment 1 Mark Montague 2006-02-12 04:06:07 EST
oops, I didn't fully describe the hang (and didn't proofread too well, sorry),
and I'm guessing (but haven't tested) that the way to duplicate is to:

-- scratch install fc3 from iso images, choose minimal install
-- download shadow-utils-4.0.3-56.x86_64.rpm
-- rpm -v -i shadow-utils-4.0.3-56.x86_64.rpm
-- look! it hangs and top thinks it's using a terabyte of VM!

this assumes that whatever made a lastlog entry for nfsnobody during my install
is repeatable. But from googling, it appears that the huge lastlog file is not
too rare an issue for 64bit fedora/rh systems.
Comment 2 Peter Vrabec 2006-02-13 08:42:50 EST
This bug is fixed in FC-4.

Huge lastlog file was created during nfs-utils instalation on 64bit platforms.

>I don't see an easy way of getting the /var/log/lastlog file to go into "huge"
>mode again without scratch installing the whole system, which I really don't
have >time to do right now-- sorry.
There's no need to do this.

Note You need to log in before you can comment on or make changes to this bug.