Bug 181063 - kernel-2.6.15-1.1928_FC5 breaks wintv-novaT (budget dvb pci)
kernel-2.6.15-1.1928_FC5 breaks wintv-novaT (budget dvb pci)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 12:05 EST by Tom Seeley
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-17 12:34:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.config for 2.6.15 (53.67 KB, text/plain)
2006-03-17 10:13 EST, Tom Seeley
no flags Details
dmesg for 2.6.15 (19.43 KB, text/plain)
2006-03-17 10:15 EST, Tom Seeley
no flags Details
lsmod for running 2.6.15 (2.67 KB, text/plain)
2006-03-17 10:20 EST, Tom Seeley
no flags Details
.config for 2.6.16-rc3 (54.84 KB, text/plain)
2006-03-17 10:35 EST, Tom Seeley
no flags Details
dmesg for 2.6.16-rc3 (21.96 KB, text/plain)
2006-03-17 10:36 EST, Tom Seeley
no flags Details
lsmod for running 2.6.16-rc3 (2.83 KB, text/plain)
2006-03-17 10:41 EST, Tom Seeley
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 6170 None None None Never

  None (edit)
Description Tom Seeley 2006-02-12 12:05:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060207 Fedora/1.5.0.1-2.1 Firefox/1.5.0.1

Description of problem:
devices for wintv-novaT (budget dvb pci saa7146) are not created in /dev/dvb when booting kernel-2.6.15-1.1928_FC5.

Problem not observed in kernel-2.6.15-1.1826.2.10_FC5 or when using different class of dvb device (freecom usb dvb works as expected in kernel-2.6.15-1.1928_FC5.)

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1928_FC5

How reproducible:
Always

Steps to Reproduce:
1.  Boot kernel-2.6.15-1.1928_FC5.
2.  ls /dev/dvb


Actual Results:  no device file seen for the Wintv novaT

Expected Results:  ls should have listed "adaptor0"

Additional info:
Comment 1 Jiri Slaby 2006-02-19 05:14:45 EST
What udev version do you use? From fc5t2, or rawhide (devel tree)?
Could you please run udevmonitor, rmmod the module and reprobe it back again and
post the result?
I changed some things in the driver, but there is no apparent error, that may
change this.
Comment 2 Rahul Sundaram 2006-02-20 06:13:36 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Tom Seeley 2006-02-21 18:28:27 EST
# rpm -q udev
udev-084-1.1

modprobe -r budget, followed by a modprobe budget:

UEVENT[1140564576.966001] remove@/bus/pci/drivers/budget dvb
UEVENT[1140564576.966888] remove@/module/budget
UEVENT[1140564576.968073] remove@/module/s5h1420
UEVENT[1140564576.969554] remove@/module/l64781
UEVENT[1140564576.971307] remove@/module/ves1820
UEVENT[1140564576.971378] remove@/module/budget_core
UEVENT[1140564576.973235] remove@/module/saa7146
UEVENT[1140564576.974838] remove@/module/ttpci_eeprom
UEVENT[1140564576.976474] remove@/module/stv0299
UEVENT[1140564576.978047] remove@/module/tda8083
UEVENT[1140564576.978805] remove@/module/ves1x93
UEVENT[1140564649.270378] add@/module/ves1x93
UEVENT[1140564649.272769] add@/module/tda8083
UEVENT[1140564649.275478] add@/module/stv0299
UEVENT[1140564649.277811] add@/module/ttpci_eeprom
UEVENT[1140564649.281126] add@/module/saa7146
UEVENT[1140564649.284391] add@/module/budget_core
UEVENT[1140564649.286788] add@/module/ves1820
UEVENT[1140564649.289229] add@/module/l64781
UEVENT[1140564649.291754] add@/module/s5h1420
UEVENT[1140564649.294722] add@/module/budget
UEVENT[1140564649.294957] add@/bus/pci/drivers/budget dvb
Comment 4 Jiri Slaby 2006-02-27 06:15:59 EST
Could you compile vanilla kernel? Could you bisect it (git bisect) to point out
accurate patch, that causes it?
Comment 5 Tom Seeley 2006-03-05 11:29:02 EST
Device works as expected in vanilla 2.6.15, but not in 2.6.16-rc5 
Comment 6 Jiri Slaby 2006-03-05 14:36:09 EST
Ok, it's ~5000 patches, could you bisect it
(http://www.kernel.org/pub/software/scm/git/docs/git-bisect.html)? Could you
attach dmesg and .config? Could you post it all to
http://bugme.osdl.org/show_bug.cgi?id=6170
Comment 7 Tom Seeley 2006-03-17 10:13:54 EST
Created attachment 126276 [details]
.config for 2.6.15
Comment 8 Tom Seeley 2006-03-17 10:15:10 EST
Created attachment 126277 [details]
dmesg for 2.6.15
Comment 9 Tom Seeley 2006-03-17 10:20:39 EST
Created attachment 126278 [details]
lsmod for running 2.6.15
Comment 10 Tom Seeley 2006-03-17 10:35:19 EST
Created attachment 126279 [details]
.config for 2.6.16-rc3
Comment 11 Tom Seeley 2006-03-17 10:36:58 EST
Created attachment 126280 [details]
dmesg for 2.6.16-rc3
Comment 12 Tom Seeley 2006-03-17 10:41:33 EST
Created attachment 126281 [details]
lsmod for running 2.6.16-rc3
Comment 13 Jiri Slaby 2006-03-17 11:03:43 EST
In 2.6.15 there isn't stradis module linked in and it works properly? You are
now using stradis driver and it is seems to be defunct with your card, try
another driver.
Comment 14 Tom Seeley 2006-03-17 11:10:41 EST
I'm not telling anything to do anything with "stradis" I'd never heard of it
prior to this bug.  There is no mention of stradis in my modprobe.conf, both
kernels have stradis compiled in as a module.  The only way I can think of
stopping stradis loading would be to remove it from my kernel build, which seems
a bit of a hack.  But even then, that wouldn't help me when I go back to a
vendor (fedora) supplied kernel.

Also note that to date I haven't succeeded in bisecting the kernel any more
accurately that above.  My first bisect between these 2 releases creates a
kernel that causes an oops when udev starts (oops mentions stradis).  I will,
hopefully be able to attach the oops to this bug later.

Tom.
Comment 15 Jiri Slaby 2006-03-17 11:18:24 EST
Aha, doesn't matter, dmesg tells.
The problem is, that there are more devices with same vendor/product id without
subvendor ids (evil(TM)), in this case, stradis tries to get control of the
card. Try to put it on blacklist (/etc/modprobe.d/blacklist would be the right
place, at least on fc5 test) and reboot.
Bisecting won't be needed, I think, we'll see, thought.
Comment 16 Tom Seeley 2006-03-17 12:17:14 EST
The blacklist entry for stradis does indeed solve my problem.

Thanks.
Comment 17 Jiri Slaby 2006-03-17 12:28:16 EST
Ok, thank you for cooperation, could you close the bug, I haven't sufficient
privileges.

Note You need to log in before you can comment on or make changes to this bug.