Bug 1812127 - /usr/libexec/chrony-helper: line 65: comm: command not found
Summary: /usr/libexec/chrony-helper: line 65: comm: command not found
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 32
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-10 15:07 UTC by Jiri Konecny
Modified: 2020-03-16 18:54 UTC (History)
6 users (show)

Fixed In Version: lorax-32.7-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-16 18:54:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Jiri Konecny 2020-03-10 15:07:15 UTC
Description of problem:
During the start of the Rawhide netinst boot.iso I see this error. Not sure if this has bigger consequences but it would be great to solve this.


Version-Release number of selected component (if applicable):
Lorax=32.5-1

How reproducible:
Always

Steps to Reproduce:
1. Run boot.iso
2. look for `/usr/libexec/chrony-helper: line 65: comm: command not found` line in journalctl

Actual results:
This line is in journal:
/usr/libexec/chrony-helper: line 65: comm: command not found

Expected results:
Chrony should not complain about missing command in stage2 image.

Comment 1 Jiri Konecny 2020-03-10 15:30:02 UTC
This is happening only on Fedora 32. It seems that this is solved in Rawhide.

Feel free to close this because I don't see any direct impact for users on Fedora 32.

Comment 2 Brian Lane 2020-03-10 16:02:56 UTC
How was it fixed on rawhide? comm has never been present in the boot.iso:

runtime-cleanup.tmpl:removefrom coreutils /usr/bin/cksum /usr/bin/comm /usr/bin/csplit

Comment 3 Jiri Konecny 2020-03-11 09:02:54 UTC
Good question, maybe chrony does not using comm command anymore?

Maybe asking maintainer? Could you please tell us. I wasn't able to spot anything in rpms but maybe I just don't know what I'm looking for.

Comment 4 Miroslav Lichvar 2020-03-11 09:11:40 UTC
That command would normally be executed only if the DHCP server provided a NTP server and NetworkManager or dhclient executed the chrony dispatcher script. Maybe something changed in those packages?

Comment 5 Jiri Konecny 2020-03-11 11:13:10 UTC
Hi Thomas, could you please tell us if NetworkManager have changed as described at comment 4.

Comment 6 Thomas Haller 2020-03-11 12:02:16 UTC
I am not aware of relevant changes in NetworkManager.

However, one idea is that we move the chrony dispatcher script from /etc/NetworkManager/dispatcher.d to /usr/lib/NetworkManager.dispatcher.d. Thereby, the SELinux label was wrong, which may result in the script failing. Do you see SELinux warnings about this? (there is also a bug reported about that, possibly even fixed already. Dunno).

Comment 7 Brian Lane 2020-03-11 15:46:02 UTC
Ok, so it sounds like it still needs comm, it just isn't always called but I see it is still present in the helper script on rawhide.
It also looks like it depends on dig, which we also remove from the boot.iso

They are also not listed in the chrony.spec (not that it would help in this case, lorax removes them unconditionally) but they should be added just to be sure there aren't other situations where they are missing.

PR is here - https://github.com/weldr/lorax/pull/978

This should probably also go into F32.


Note You need to log in before you can comment on or make changes to this bug.