Bug 1812600 - openshift_control_plane/tasks/update_master_count.yml restarting api/controllers
Summary: openshift_control_plane/tasks/update_master_count.yml restarting api/controllers
Keywords:
Status: CLOSED DUPLICATE of bug 1826765
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.11.z
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 16:31 UTC by dtarabor
Modified: 2020-05-12 20:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-12 20:08:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description dtarabor 2020-03-11 16:31:50 UTC
Description of problem:

CU has commented out: "notify: restart master" in roles/openshift_control_plane/tasks/update_master_count.yml to avoid restarting api/controllers. Would like to know if this is something that can be removed from future releases or if it's needed.

[root@lpdospeu50205 ~]# rpm -q openshift-ansible
openshift-ansible-3.11.92-1.git.0.f2fade7.el7.noarch

[root@lpdospeu50205 ~]# rpm -q ansible
ansible-2.6.15-1.el7ae.noarch

[root@lpdospeu50205 ~]# ansible --version
ansible 2.6.15
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /bin/ansible
  python version = 2.7.5 (default, Jun 11 2019, 14:33:56) [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]


How reproducible:

Every time

Steps to Reproduce:

We have commented out the "notify: restart master" in roles/openshift_control_plane/tasks/update_master_count.yml to avoid restarting api/controllers and have not noticed any issues.

Have found these links that seem to indicate that what roles/openshift_control_plane/tasks/update_master_count.yml is doing is not needed anymore:

https://github.com/openshift/origin/pull/19183
https://github.com/openshift/origin/pull/19186/files


Additional info:
CU would like to know if this is a needed step, or if it can safely be removed from future releases

Comment 1 Brenton Leanhardt 2020-05-12 20:08:06 UTC
We should indeed remove this.  Please follow https://bugzilla.redhat.com/show_bug.cgi?id=1826765 for updates.

*** This bug has been marked as a duplicate of bug 1826765 ***


Note You need to log in before you can comment on or make changes to this bug.