Bug 181308 - useradd doesn't create users
useradd doesn't create users
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 07:26 EST by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 02:21:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2006-02-13 07:26:15 EST
Description of problem:
"useradd username" creates /home/username folder, but it doesn't add the user to
/etc/passwd and /etc/shadow
No error is shown on screen or /var/log/messages:

[root@mariusa-ro ~]# useradd a2
[root@mariusa-ro ~]# passwd a2
passwd: Unknown user name 'a2'.

SELinux is disabled.

How reproducible:
100%
Comment 1 Peter Vrabec 2006-02-13 08:23:08 EST
I can't reproduce it.

# getenforce
Disabled
# useradd a2
# id a2
uid=511(a2) gid=544(a2) groups=544(a2)
# passwd a2
Changing password for user a2.
New UNIX password:
Retype new UNIX password:
passwd: all authentication tokens updated successfully.
# rpm -q shadow-utils
shadow-utils-4.0.12-7.FC4
# rpm -q fedora-release
fedora-release-4-2
Comment 2 Marius Andreiana 2006-02-13 11:11:31 EST
$ rpm -q shadow-utils
shadow-utils-4.0.7-10.FC4
$ rpm -q fedora-release
fedora-release-4-2

What other debugging information could I offer?

Thanks
Comment 3 Peter Vrabec 2006-02-13 11:51:12 EST
Could u update shadow-utils and try it again.
Comment 4 Marius Andreiana 2006-02-14 02:10:27 EST
I tested again today and it works. Looks like an passwd.lock file was left around. 

Thanks

Note You need to log in before you can comment on or make changes to this bug.