Bug 181317 - G++ segfaults when compiling a simple test example using Qt 3.3.4
Summary: G++ segfaults when compiling a simple test example using Qt 3.3.4
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-13 14:18 UTC by Hristo Atanassov Ivanov
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 14:37:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The test project (11.93 KB, application/x-bzip2)
2006-02-13 14:20 UTC, Hristo Atanassov Ivanov
no flags Details
The output that gcc requested to be sent here. (1.05 MB, application/octet-stream)
2006-02-13 14:22 UTC, Hristo Atanassov Ivanov
no flags Details

Description Hristo Atanassov Ivanov 2006-02-13 14:18:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When compiling simple test project, G++ segfaults. It happens with other projects occasionally, a simple "make" to continue the build process worked (seemed that this thing happened rarely and was related to a hardware failiure since the bug appeared for random files and was not easily reproducable -- when I tried to compile them again, g++ compiled them just fine). Not this time, though

Version-Release number of selected component (if applicable):
4.0.2-8.fc4

How reproducible:
Always

Steps to Reproduce:
1.Unpack the archive
2.run make

  

Actual Results:  cd '/home/gadnio/test/qt_test' && QTDIR="/usr/lib/qt-3.3" gmake -k 
cd src && gmake -f Makefile
g++ -c -pipe -Wall -W -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -DQT_NO_DEBUG -DQT_SHARED -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.3/mkspecs/default -I. -I/usr/lib/qt-3.3/include -o qt_test.o qt_test.cpp
/usr/lib/qt-3.3/include/qglist.h: In member function virtual uint QGList::count() const:
/usr/lib/qt-3.3/include/qglist.h:153: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccFDTzaM.out file, please attach this to your bugreport.
g++ -c -pipe -Wall -W -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -DQT_NO_DEBUG -DQT_SHARED -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.3/mkspecs/default -I. -I/usr/lib/qt-3.3/include -o w.o w.cpp
gmake[1]: *** [qt_test.o] Error 1
w.cpp:44: warning: unused parameter parent
w.cpp:44: warning: unused parameter name
w.cpp:44: warning: unused parameter f
/usr/lib/qt-3.3/include/qglist.h: In member function virtual uint QGList::count() const:
/usr/lib/qt-3.3/include/qglist.h:153: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccOJcZjY.out file, please attach this to your bugreport.
/usr/lib/qt-3.3/bin/moc w.h -o moc_w.cpp
gmake[1]: *** [w.o] Error 1
g++ -c -pipe -Wall -W -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -DQT_NO_DEBUG -DQT_SHARED -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.3/mkspecs/default -I. -I/usr/lib/qt-3.3/include -o moc_w.o moc_w.cpp
/usr/lib/qt-3.3/include/private/qucom_p.h:69: warning: struct QUBuffer has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:77: warning: struct QUType has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:104: warning: struct QUType_Null has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:287: warning: struct QUType_enum has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:307: warning: struct QUType_ptr has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:326: warning: struct QUType_iface has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:345: warning: struct QUType_idisp has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:364: warning: struct QUType_bool has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:383: warning: struct QUType_int has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:403: warning: struct QUType_double has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:423: warning: struct QUType_charstar has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucom_p.h:444: warning: struct QUType_QString has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucomextra_p.h:65: warning: struct QUType_QVariant has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucomextra_p.h:87: warning: struct QUType_varptr has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/qglist.h: In member function virtual uint QGList::count() const:
/usr/lib/qt-3.3/include/qglist.h:153: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cctx5ieI.out file, please attach this to your bugreport.
gmake[1]: *** [moc_w.o] Error 1
gmake[1]: Target `first' not remade because of errors.
gmake: *** [sub-src] Error 2
gmake: Target `first' not remade because of errors.
*** Exited with status: 2 ***


Expected Results:  comiling the project

Additional info:

[root@Apocalypse exscalibar-1.0.4]# uname -a
Linux Apocalypse.n7 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 athlon i386 GNU/Linux

Comment 1 Hristo Atanassov Ivanov 2006-02-13 14:20:22 UTC
Created attachment 124564 [details]
The test project

This is the project that generates the segfault.

Comment 2 Hristo Atanassov Ivanov 2006-02-13 14:22:38 UTC
Created attachment 124565 [details]
The output that gcc requested to be sent here.


Note You need to log in before you can comment on or make changes to this bug.