Bug 18133 - broken logging
Summary: broken logging
Status: CLOSED DUPLICATE of bug 17420
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mgetty   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 20:20 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 20:20:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-10-02 20:20:30 UTC
mgetty-1.1.22-1 has a bad logging-behavior because it outputs at
successful operations (loglevel L_MESG) the errno-string. An example
output is

| Sep 27 22:53:14 feldi mgetty[11711]: waiting...: No such file or
directory

The reason lies in mgetty-1.1.22-excl.patch removing the parts of logfile.c
which are handling harmless messages. Now 

| syslog( level == L_FATAL? LOG_ALERT: LOG_ERR, "%s: %m", ws );

will be called also if level is L_MESG only.

Comment 1 Bill Nottingham 2000-10-02 22:27:32 UTC

*** This bug has been marked as a duplicate of 17420 ***


Note You need to log in before you can comment on or make changes to this bug.