Bug 181338 - Missing include files in kernel-xen-*-devel packages
Summary: Missing include files in kernel-xen-*-devel packages
Status: CLOSED DUPLICATE of bug 180198
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Juan Quintela
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-13 16:15 UTC by Jos Vos
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 16:30:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix to include xen directory in kernel-xen-*-devel packages (546 bytes, patch)
2006-02-17 12:41 UTC, Jos Vos
no flags Details | Diff

Description Jos Vos 2006-02-13 16:15:41 UTC
Description of problem:

When trying to build an external kernel module for kernel-xen-hypervisor (with
kernel-xen-hypervisor-devel installed) I get:

include/asm-i386/mach-xen/mach_page.h:10:31: xen/interface/xen.h: No such file
or directory
include/asm-i386/mach-xen/mach_page.h:11:30: xen/foreign_page.h: No such file or
directory

As these files are referred to in include/asm-i386/mach-xen/mach_page.h, it
seems that at least these files should have been included in the devel packages
(and maybe more?).

Version-Release number of selected component (if applicable):
2.6.15-1.40_FC5

Comment 1 Bill Nottingham 2006-02-13 16:30:38 UTC

*** This bug has been marked as a duplicate of 180198 ***

Comment 2 Jos Vos 2006-02-17 12:41:38 UTC
Created attachment 124813 [details]
Fix to include xen directory in kernel-xen-*-devel packages

The attached small patch adds the include/xen directory and it works for me. 
Maybe too much files are included now (but at least it's better than too few
;-)).

The pactch is for kernel-2.6.spec for 2.6.15-1.1948_FC5.

Comment 3 Jos Vos 2006-02-17 12:43:07 UTC
Oops... will attach the same patch to 180198.


Note You need to log in before you can comment on or make changes to this bug.