Bug 181340 - Autoconf X checking error with XrmInitialize
Autoconf X checking error with XrmInitialize
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Brian Brock
http://www.redhat.com/archives/fedora...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 11:29 EST by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 06:36:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated autoconf-intrinsic patch that fixes upstream bug (1.28 KB, patch)
2006-02-14 13:35 EST, Toshio Kuratomi
no flags Details | Diff

  None (edit)
Description Matthias Saou 2006-02-13 11:29:10 EST
With :
autoconf-2.59-6
automake-1.9.6-2
libtool-1.5.22-2.2

See the devel list posting linked in the URL field. Basically, after an
autoreconf, the configure X checking fails because of a :

void XrmInitialize( void ) (what the real call should be)

vs.

void XrmInitialize( int ) (what autoconf checks with int=0)

This results in a failed check with :

too many arguments to function 'void XrmInitialize()'
Comment 1 Toshio Kuratomi 2006-02-14 13:35:52 EST
Created attachment 124634 [details]
Updated autoconf-intrinsic patch that fixes upstream bug

Upstream seems to have munged the function when adopting the debian
maintainer's patch.  The initial report upstream and
ftp.debian.org:/debian/pool/main/a/autoconf/autoconf_2.59a-7.diff.gz has
XrmInitialize() rather than XrmInitialize(0).

Matthias, can you test this?
Comment 2 Matthias Saou 2006-02-15 06:33:18 EST
It works fine for me now :-)
Now I just need the fix to appear in Rawhide so that I can rebuild synergy in
Extras...
Comment 3 Karsten Hopp 2006-02-15 06:36:27 EST
fixed in -7, but that may take a while to appear in Rawhide as we're preparing
for  test3
Comment 4 Toshio Kuratomi 2006-02-15 13:18:13 EST
Issue and patch submitted upstream as well.

Note You need to log in before you can comment on or make changes to this bug.