Bug 181350 - Incorrect memory usage info in linux 64bit
Incorrect memory usage info in linux 64bit
Status: CLOSED DUPLICATE of bug 181348
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 11:52 EST by Rajdeep Sengupta
Modified: 2013-08-05 21:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 15:37:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajdeep Sengupta 2006-02-13 11:52:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
We want to report runtime memory usage in our application running on linux 64bit. We do not know any API which we can use it in our application so that it reports correct result over 2GB of memeory.
So please let me know if there is any API for the same. Suppose there is no such API present in the current release, then could you send us a shared library which we can overload in our application which will keep track of the memory usage and report it correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Whenever we run our application and the meemory usage goes more than 2GB
2.
3.
  

Actual Results:  As we use the mallinfo, it returns in correct info above 2GB

Expected Results:  Correct usage reeport

Additional info:
Comment 1 Ernie Petrides 2006-02-13 15:37:14 EST
This is apparently an accidental duplicate entry.

*** This bug has been marked as a duplicate of 181348 ***

Note You need to log in before you can comment on or make changes to this bug.